Error when using sqlsrv.so and pdo_sqlsrv.so

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error when using sqlsrv.so and pdo_sqlsrv.so

Postby tasso85 » 28. March 2017 09:29

Hi,

I was doing some tests, building the new SQL Server extension for linux PHP from source, and while the build went smoothly, when loading them through php.ini I get these errors:

Code: Select all
Warning: PHP Startup: Unable to load dynamic library '/opt/agews64/lib/php/current/sqlsrv.so' - /opt/lampp/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /opt/agews64/lib/php/current/sqlsrv.so) in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library '/opt/agews64/lib/php/current/pdo_sqlsrv.so' - /opt/lampp/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /opt/agews64/lib/php/current/pdo_sqlsrv.so) in Unknown on line 0


I *think* I fixed this by re-linking
Code: Select all
/opt/lampp/lib/libstdc++.so.6
from
Code: Select all
/opt/lampp/lib/libstdc++.so.6.0.8
to
Code: Select all
/lib64/libstdc++.so.6.0.19
and the error went away.

Has any of you experienced similar errors?
tasso85
 
Posts: 9
Joined: 16. May 2016 11:19
XAMPP version: 7.0.5
Operating System: Centos 7 64bit

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests