imagick problem Class 'Imagick' not found

Problems with the Linux version of XAMPP, questions, comments, and anything related.

imagick problem Class 'Imagick' not found

Postby b3nhysteria » 02. November 2016 10:25

hi all, i need some help here, i want use ImageMagick for my php laravel,

but i got problem error "Class 'Imagick' not found"

so i want install imagemagick for solved this problem

but i got stuck in

Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20131226/' - /opt/lampp/lib/ version `CXXABI_1.3.8' not found (required by /lib64/ in Unknown on line 0

when i try to test my installation tar.gz from with convert -version
i got Version:
ImageMagick 7.0.3-5 Q16 x86_64 2016-11-02
Copyright: Copyright (C) 1999-2016 ImageMagick Studio LLC
Features: Cipher DPC HDRI OpenMP
Delegates (built-in): bzlib djvu fontconfig freetype jng jpeg lzma openexr pangocairo png tiff wmf x xml zlib

is anyone have got same problem? how do you solved it?

i try to update LD_LIBRARY_PATH, but still got not solved it..

help me..
Posts: 1
Joined: 02. November 2016 10:17
XAMPP version: 5.6.24-1
Operating System: fedora 24 64 bit

Re: imagick problem Class 'Imagick' not found

Postby Nobbie » 02. November 2016 19:31

You cannot install that foreign binary into Xampp. if you need your own binary extensions, do not use Xampp, use the Apache/PHP/MySQL installation from your distribution instead.
Posts: 10034
Joined: 09. March 2008 13:04

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests