Error Access / Privileges / All DB

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error Access / Privileges / All DB

Postby Danymc » 28. September 2016 19:01

http://localhost/phpmyadmin/


Cannot log in to the MySQL server
Connection for controluser as defined in your configuration failed.


root@ServidorAplis:/home/rootapps# /opt/lampp/xampp stop
Stopping XAMPP for Linux 5.6.20-0...
XAMPP: Stopping Apache...ok.
XAMPP: Stopping MySQL...ok.
XAMPP: Stopping ProFTPD...ok.
root@ServidorAplis:/home/rootapps#


root@ServidorAplis:/home/rootapps# /opt/lampp/xampp security
XAMPP: Quick security check...
XAMPP: Your XAMPP pages are NOT secured by a password.
XAMPP: Do you want to set a password? [yes]
XAMPP: Password: root
XAMPP: Password (again): root

/opt/lampp/share/xampp/checkapache: línea 41: /opt/lampp/htdocs/xampp/.htaccess: No existe el archivo o el directorio
cp: no se puede efectuar `stat' sobre '/opt/lampp/htdocs/xampp/.htaccess': No existe el archivo o el directorio
cp: no se puede efectuar `stat' sobre '/opt/lampp/htdocs/xampp/.htaccess': No existe el archivo o el directorio
chmod: no se puede acceder a '/opt/lampp/htdocs/xampp/.htaccess': No existe el archivo o el directorio
chmod: no se puede acceder a '/opt/lampp/htdocs/webalizer/.htaccess': No existe el archivo o el directorio
chmod: no se puede acceder a '/opt/lampp/phpmyadmin/.htaccess': No existe el archivo o el directorio
XAMPP: Password protection active. Please use 'xampp' as user name!
XAMPP: MySQL is not accessable via network. Good.
XAMPP: MySQL has to run before I can check the security.
XAMPP: MySQL has to run before I can check the security.
XAMPP: MySQL has a root passwort set. Fine! :)
XAMPP: ProFTPD has a new FTP password. Great!
XAMPP: Do you want to change the password anyway? [no] yes
XAMPP: Password: root
XAMPP: Password (again): root
XAMPP: Reload ProFTPD...not running.
XAMPP: Done.
root@ServidorAplis:/home/rootapps#

root@ServidorAplis:/home/rootapps# sudo geany /reparar

Code: Select all
[color=#004000][b]SET PASSWORD FOR 'root'@'localhost' = PASSWORD('root'); FLUSH PLIVILEGES;[/b][/color]


SAVE

root@ServidorAplis:/home/rootapps#
sudo /opt/lampp/bin/mysqld_safe --init-file=/reparar --user=root --skip-grant-tables --skip-networking

2016-09-28 15:51:06 28292 mysqld_safe Logging to '/opt/lampp/var/ServidorAplis.err'.
2016-09-28 15:51:06 28292 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var
2016-09-28 15:51:08 28292 mysqld_safe mysqld from pid file /opt/lampp/var/ServidorAplis.pid ended
root@ServidorAplis:/home/rootapps#



root@ServidorAplis:/home/rootapps# /opt/lampp/xampp start
Starting XAMPP for Linux 5.6.20-0...
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.



http://localhost/phpmyadmin/index.php

Cannot log in to the MySQL server
Connection for controluser as defined in your configuration failed.


root@ServidorAplis:/home/rootapps# [color=#0000FF]sudo geany /opt/lampp/phpmyadmin/config.inc.php[/color]



$cfg['blowfish_secret'] = 'xampp';

$i = 0;
$i++;

/* Authentication type */

# commented out by xampp security
#$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'root';

/* Server parameters */


# $cfg['Servers'][$i]['host'] = 'localhost';
# $cfg['Servers'][$i]['connect_type'] = 'tcp';


$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['AllowNoPassword'] = true;

/**
* phpMyAdmin configuration storage settings.
*/

/* User used to manipulate with storage */
// $cfg['Servers'][$i]['controlhost'] = '';
// $cfg['Servers'][$i]['controlport'] = '';

$cfg['Servers'][$i]['controluser'] = 'pma';


# commented out by xampp security
# $cfg['Servers'][$i]['controlpass'] = '';

$cfg['Servers'][$i]['controlpass'] = 'root';

/* Storage database and tables */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma__bookmark';
$cfg['Servers'][$i]['relation'] = 'pma__relation';
$cfg['Servers'][$i]['table_info'] = 'pma__table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma__table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma__pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma__column_info';
$cfg['Servers'][$i]['history'] = 'pma__history';
$cfg['Servers'][$i]['table_uiprefs'] = 'pma__table_uiprefs';
$cfg['Servers'][$i]['tracking'] = 'pma__tracking';
$cfg['Servers'][$i]['userconfig'] = 'pma__userconfig';
$cfg['Servers'][$i]['recent'] = 'pma__recent';
$cfg['Servers'][$i]['users'] = 'pma__users';
$cfg['Servers'][$i]['usergroups'] = 'pma__usergroups';
$cfg['Servers'][$i]['navigationhiding'] = 'pma__navigationhiding';
$cfg['Servers'][$i]['savedsearches'] = 'pma__savedsearches';
$cfg['Servers'][$i]['central_columns'] = 'pma__central_columns';
$cfg['Servers'][$i]['designer_coords'] = 'pma__designer_coords';
$cfg['Servers'][$i]['designer_settings'] = 'pma__designer_settings';
$cfg['Servers'][$i]['export_templates'] = 'pma__export_templates';
$cfg['Servers'][$i]['favorite'] = 'pma__favorite';
// $cfg['Servers'][$i]['favorite'] = 'pma__favorite';
// $cfg['Servers'][$i]['users'] = 'pma__users';
// $cfg['Servers'][$i]['usergroups'] = 'pma__usergroups';
// $cfg['Servers'][$i]['navigationhiding'] = 'pma__navigationhiding';
// $cfg['Servers'][$i]['savedsearches'] = 'pma__savedsearches';
// $cfg['Servers'][$i]['central_columns'] = 'pma__central_columns';
// $cfg['Servers'][$i]['designer_settings'] = 'pma__designer_settings';
// $cfg['Servers'][$i]['export_templates'] = 'pma__export_templates';

/* Contrib / Swekey authentication */
// $cfg['Servers'][$i]['auth_swekey_config'] = '/etc/swekey-pma.conf';


/**
* Directories for saving/loading files from server
*/
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';


//$cfg['ShowAll'] = true;


//$cfg['MaxRows'] = 200;

/**
* Disallow editing of binary fields
* valid values are:
* false allow editing
* 'blob' allow editing except for BLOB fields
* 'noblob' disallow editing except for BLOB fields
* 'all' disallow editing
* default = 'blob'
*/
//$cfg['ProtectBinary'] = false;


//$cfg['DefaultLang'] = 'en';




Close File


root@ServidorAplis:/home/rootapps# sudo geany /opt/lampp/var/ServidorAplis.err




2016-09-28 15:53:13 28538 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var
2016-09-28 15:53:13 139725420267328 [Note] Using unique option prefix 'key_buffer' is error-prone and can break in the future. Please use the full name 'key_buffer_size' instead.
2016-09-28 15:53:13 139725420267328 [Warning] Ignoring user change to 'root' because the user was set to 'mysql' earlier on the command line

2016-09-28 15:53:13 139725420267328 [Note] /opt/lampp/sbin/mysqld (mysqld 10.1.13-MariaDB) starting as process 28699 ...
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: The InnoDB memory heap is disabled
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Memory barrier is not used
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Compressed tables use zlib 1.2.8
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Using SSE crc32 instructions
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Completed initialization of buffer pool
2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Highest supported file format is Barracuda.
2016-09-28 15:53:13 7f145c0a8740 InnoDB: Operating system error number 2 in a file operation.
InnoDB: The error means the system cannot find the path specified.
InnoDB: If you are installing InnoDB, remember that you must create
InnoDB: directories yourself, InnoDB does not create them.
2016-09-28 15:53:13 139725420267328 [ERROR] InnoDB: Could not find a valid tablespace file for 'myp/capta_user'. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting-datadict.html for how to resolve the issue.
2016-09-28 15:53:13 139725420267328 [ERROR] InnoDB: Tablespace open failed for '"myp"."capta_user"', ignored.
2016-09-28 15:53:13 7f145c0a8740 InnoDB: Operating system error number 2 in a file operation.
InnoDB: The error means the system cannot find the path specified.
InnoDB: If you are installing InnoDB, remember that you must create
InnoDB: directories yourself, InnoDB does not create them.
2016-09-28 15:53:13 139725420267328 [ERROR] InnoDB: Could not find a valid tablespace file for 'myp/devyabonosc'. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting-datadict.html for how to resolve the issue.
...
...

2016-09-28 15:53:13 139725420267328 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.28-76.1 started; log sequence number 25637129
2016-09-28 15:53:13 139725115025152 [Note] InnoDB: Dumping buffer pool(s) not yet started
2016-09-28 15:53:13 139725420267328 [ERROR] mysqld: Can't create/write to file '/opt/lampp/var/aria_log_control' (Errcode: 13 "Permission denied")
2016-09-28 15:53:13 139725420267328 [ERROR] mysqld: Got error 'Can't create file' when trying to use aria control file '/opt/lampp/var/aria_log_control'
2016-09-28 15:53:13 139725420267328 [ERROR] Plugin 'Aria' init function returned error.
2016-09-28 15:53:13 139725420267328 [ERROR] Plugin 'Aria' registration as a STORAGE ENGINE failed.
2016-09-28 15:53:13 139725420267328 [Note] Plugin 'FEEDBACK' is disabled.
2016-09-28 15:53:13 139725420267328 [ERROR] Aria engine is not enabled or did not start. The Aria engine must be enabled to continue as mysqld was configured with --with-aria-tmp-tables
2016-09-28 15:53:13 139725420267328 [ERROR] Aborting

2016-09-28 15:53:15 28538 mysqld_safe mysqld from pid file /opt/lampp/var/ServidorAplis.pid ended


---

--------------------------------- ----------------------------------------
abort-source-on-error FALSE
auto-rehash FALSE
auto-vertical-output FALSE
character-sets-dir (No default value)
column-type-info FALSE
comments FALSE
compress FALSE
debug-check FALSE
debug-info FALSE
database (No default value)
default-character-set auto
delimiter ;
vertical FALSE
force FALSE
named-commands FALSE
ignore-spaces FALSE
init-command (No default value)
local-infile FALSE
no-beep FALSE
host (No default value)
html FALSE
xml FALSE
line-numbers TRUE
unbuffered FALSE
column-names TRUE
sigint-ignore FALSE
port 3306
progress-reports TRUE
prompt \N [\d]>
quick FALSE
raw FALSE
reconnect TRUE
socket /opt/lampp/var/mysql/mysql.sock
ssl FALSE
ssl-ca (No default value)
ssl-capath (No default value)
ssl-cert (No default value)
ssl-cipher (No default value)
ssl-key (No default value)
ssl-crl (No default value)
ssl-crlpath (No default value)
ssl-verify-server-cert FALSE
table FALSE
user (No default value)
safe-updates FALSE
i-am-a-dummy FALSE
connect-timeout 0
max-allowed-packet 16777216
net-buffer-length 16384
select-limit 1000
max-join-size 1000000
secure-auth FALSE
show-warnings FALSE
plugin-dir (No default value)
default-auth (No default value)
binary-mode FALSE





root@ServidorAplis:/home/rootapps# /opt/lampp/bin/mysql --user=root -p
Enter password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
root@ServidorAplis:/home/rootapps#
Danymc
 
Posts: 1
Joined: 28. September 2016 18:49
XAMPP version: Last
Operating System: Ubuntu Server

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests