Error trying to run appache on Ubuntu

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error trying to run appache on Ubuntu

Postby Twigster » 07. September 2016 18:05

Hello all!

I am getting this log when trying to run the appache web server through xampp on Ubuntu.

Starting Apache Web Server...
Exit code: 8
apache config test fails, aborting
httpd: Syntax error on line 136 of /opt/lampp/etc/httpd.conf: Cannot load modules/ into server: /opt/lampp/modules/ cannot open shared object file: No such file or directory

I tried looking up a solution and checked out the file, but I can't seem to find the answer.

If you can help that would be great! Thank you!
Posts: 1
Joined: 07. September 2016 17:57
XAMPP version: 5.6.24-0
Operating System: Ubuntu

Re: Error trying to run appache on Ubuntu

Postby Nobbie » 07. September 2016 21:43

That is an already known severe bug in the current Xampp releases, it looks as Bitnami simply forgot(!) to add the module to the installation package. I asked the forum members quickly to send a request to Bitnami, but i dont know if anything has happened meanwhile.

see also


There is also a workaround in the above threads, you may comment out the corresponding line in httpd.conf, which is responsible for loading the missing module. If you dont need SSL, there is no disadvantage for you.
Posts: 8636
Joined: 09. March 2008 13:04

Return to XAMPP for Linux

Who is online

Users browsing this forum: Altrea and 9 guests