Fatal error: Can't change to run as user 'mysql' ; Please c

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Fatal error: Can't change to run as user 'mysql' ; Please c

Postby Unconformed » 01. September 2016 14:03

Hi

I just posted, and resolved my issue.

However, I have a new one right away:).

I discovered that I had a Mysql process running (despite removing mysql, or so I thought). So I followed these instructions (I have a note of the issue I think is

http://askubuntu.com/questions/640899/uninstall-mysql-completely

sudo -i
service mysql stop
killall -KILL mysql mysqld_safe mysqld
apt-get --yes purge mysql-server mysql-client
apt-get --yes autoremove --purge
apt-get autoclean
deluser --remove-home mysql ///// I think this is what has caused me the problem
delgroup mysql
rm -rf /etc/apparmor.d/abstractions/mysql /etc/apparmor.d/cache/usr.sbin.mysqld /etc/mysql /var/lib/mysql /var/log/mysql* /var/log/upstart/mysql.log* /var/run/mysqld
updatedb
exit

Xammps GUI error log

2016-09-01 22:42:08 4455 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/thomas.pid ended
2016-09-01 22:42:26 1419 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
2016-09-01 22:42:26 140344654886784 [Note] Using unique option prefix 'key_buffer' is error-prone and can break in the future. Please use the full name 'key_buffer_size' instead.
2016-09-01 22:42:26 140344654886784 [Note] /opt/lampp/sbin/mysqld (mysqld 10.1.13-MariaDB) starting as process 1629 ...
2016-09-01 22:42:26 140344654886784 [ERROR] Fatal error: Can't change to run as user 'mysql' ; Please check that the user exists!

2016-09-01 22:42:26 140344654886784 [ERROR] Aborting

2016-09-01 22:42:26 1419 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/thomas.pid ended

Another log -
/opt/lampp/logs$ sudo tail -f error_log

[Thu Sep 01 22:47:03.931530 2016] [:error] [pid 1695] [client 127.0.0.1:57927] PHP Fatal error: Could not create DB link! in /home/thomas/response/pub/lib/smrDB.class.php on line 45
Unconformed
 
Posts: 17
Joined: 27. August 2016 05:32
XAMPP version: 5.6.23
Operating System: Linux

Re: Fatal error: Can't change to run as user 'mysql' ; Plea

Postby Nobbie » 02. September 2016 12:28

Unconformed wrote:2016-09-01 22:42:26 140344654886784 [ERROR] Fatal error: Can't change to run as user 'mysql' ; Please check that the user exists!


This looks like as you crippled your Xampp installation, as you overtook the contents of httdp.conf from your Linux Apache installation to the Xampp Apache installation and the my.ini for MySQL from Ubuntu to Xampp. This results in a mess. I dont think you will fix all that stuff, if i were you, i would delete the whole /opt/lampp folder and install a new one. And the do NOT simply override the default configuration. Take it, as it is.

You may also have destroyed the Phpmyadmin installation and/or the MySQL Data in the same way. It looks as everything has severe configuration issues.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Fatal error: Can't change to run as user 'mysql' ; Plea

Postby Unconformed » 07. September 2016 09:49

ty, I re-installed and it worked, for a while. I have a new problem now (posted elsewhere here)

[Tue Sep 06 08:06:44.007907 2016] [ssl:warn] [pid 1233] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 06 08:06:44.007967 2016] [suexec:notice] [pid 1233] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Sep 06 08:06:44.034765 2016] [auth_digest:notice] [pid 1339] AH01757: generating secret for digest authentication ...
[Tue Sep 06 08:06:45.001380 2016] [ssl:warn] [pid 1339] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Sep 06 08:06:45.001404 2016] [ssl:warn] [pid 1339] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Sep 06 08:06:45.001451 2016] [lbmethod_heartbeat:notice] [pid 1339] AH02282: No slotmem from mod_heartmonitor
[Tue Sep 06 08:06:45.025535 2016] [mpm_prefork:notice] [pid 1339] AH00163: Apache/2.4.18 (Unix) OpenSSL/1.0.2h PHP/5.6.23 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
[Tue Sep 06 08:06:45.025551 2016] [core:notice] [pid 1339] AH00094: Command line: '/opt/lampp/bin/httpd -E /opt/lampp/logs/error_log -D SSL -D PHP'
[Tue Sep 06 08:11:30.936259 2016] [mpm_prefork:notice] [pid 1339] AH00169: caught SIGTERM, shutting down
Unconformed
 
Posts: 17
Joined: 27. August 2016 05:32
XAMPP version: 5.6.23
Operating System: Linux

Re: Fatal error: Can't change to run as user 'mysql' ; Plea

Postby Nobbie » 07. September 2016 11:29

There is no error in that log, only warn and notice. I also cannot find "elsewhere".
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests