Can't connect to DB

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Can't connect to DB

Postby Unconformed » 01. September 2016 12:10

Everything was fine, however now I get:

bool(false) Connection refused
Fatal error: Could not create DB link! in /home/thomas/response/pub/lib/smrDB.class.php on line 45

Logs say the same thing:

[Thu Sep 01 20:59:09.170353 2016] [:error] [pid 3609] [client 127.0.0.1:39447] PHP Fatal error: Could not create DB link! in /home/thomas/response/pub/lib/smrDB.class.php on line 45

'dbUserName' => 'root',
'dbPassword' => '',
'dbHost' => 'localhost',
'dbName' => 'response_dev',


The thing is, I had this working fine the other day. All I have done ince is disable MYSL and Apache at boot. I have not changed any config files.

Going to http://localhost/phpmyadmin/

I get access denied and

Error

MySQL said: Documentation
Cannot connect: invalid settings.
Connection for controluser as defined in your configuration failed.
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

Got any tips?
Unconformed
 
Posts: 17
Joined: 27. August 2016 05:32
XAMPP version: 5.6.23
Operating System: Linux

Re: Can't connect to DB

Postby Nobbie » 02. September 2016 12:23

Unconformed wrote:All I have done ince is disable MYSL and Apache at boot.


What is MYSL?? Seems you have MySQL and Apache installed twice?? Not only Xampp, but also from your Linux distribution?? If so, that is a bad idea, you should uninstall one of those.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests