Issue configuring apache2

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Issue configuring apache2

Postby metaing » 20. July 2016 15:43

Hello everyone!
I deployed 2 applications on my Apache: 1) A Python application developed with Django 2) A web site

First I deployed my Python application and it worked correctly, as I could invoke a REST API with a GET on
Code: Select all
<ip>/rest/combo
and I could also access static resources. Then I deployed my website both were working correctly, as I could access my website at the URL
Code: Select all
http://<ip>
and at the same time I could invoke my REST API as before, as well as I could access static resources. Last step was to set the DNS records on GoDaddy to let my domain name point to my website. After this was done, an I am finding an issue on my Python application: REST APIs gives me a 404 error both on
Code: Select all
<ip>/rest/combo
an d[/code]<domain-name>/rest/combo[/code], while static resources keep being served.

I created two configuration files in
Code: Select all
/etc/apache2/conf-enabled
:

1) For Python:
Code: Select all
WSGIScriptAlias / /home/ubuntu/MyPythonApplication/MyPythonApplication/wsgi.py
WSGIPythonPath /home/ubuntu/MyPythonApplication
<Directory /home/ubuntu/MyPythonApplication/MyPythonApplication>
    <Files wsgi.py>
        Order deny,allow
        Require all granted
    </Files>
</Directory>

Alias /media/ /home/ubuntu/MyPythonApplication/media/
Alias /static/ /home/ubuntu/MyPythonApplication/static/

<Directory /home/ubuntu/MyPythonApplication/static>
    Require all granted
</Directory>

<Directory /home/ubuntu/MyPythonApplication/media>
    Require all granted
</Directory>
Code: Select all
One for my website:

Alias / /home/ubuntu/MyWebsite/

<Directory /home/ubuntu/MyWebsite>
    Require all granted
</Directory>

I understand that the issue is on the Alias as both configuration files refers / (if I change it on my website configuration file, rest APIs work again).

I don't have an domain name for the rest APIs. How can I fix this?
metaing
 
Posts: 1
Joined: 20. July 2016 15:39
XAMPP version: 5.5.37
Operating System: Ubuntu 16.04

Re: Issue configuring apache2

Postby Nobbie » 20. July 2016 18:38

How is your question related to Xampp? This is the "Xampp for Linux" forum. Also, Python is not part of Xampp.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests