XAMPP 5.6 is currently only availably as 32 bit application?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP 5.6 is currently only availably as 32 bit application?

Postby tedvg » 20. June 2016 15:51

I have just downloaded XAMPP from the website (url: https://www.apachefriends.org/download.html, version: xampp-linux-x64-5.6.21-0-installer.run ) And tried to install it on Ubuntu 16.04. Everything installed ok, but when I run xampp from the terminal ( sudo /opt/lampp/lampp start ) I get the following message:

XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system.

When I search on the Internet, the only suggestions that are made are that the 32-bit version is installed on a 64-bit OS, but that is not the case. I also cannot find the correct 32-bit compatibility libs.

How can I run XAMPP on Ubuntu 16.04?
tedvg
 
Posts: 2
Joined: 20. June 2016 15:40
XAMPP version: 5.6.21
Operating System: Ubuntu 16.04

Re: XAMPP 5.6 is currently only availably as 32 bit applicat

Postby tedvg » 21. June 2016 21:55

Ok, I got it running by installing some 32-bit libs. From the terminal, I issued the following commands:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386
sudo apt-get install libgtk2.0-0:i386

After I start XAMMP from the terminal, I get the welcome-screen if I type localhost in my browser. Next I'm trying to restore my local websites.

Only thing that doesn't work is ProFTPD. I got the following error:

XAMPP: Starting ProFTPD...
XAMPP: /opt/lampp/sbin/proftpd: error while loading shared libraries: libmysqlclient.so.18: wrong ELF class: ELFCLASS32
XAMPP: Error 127! Couln't start ProFTPD!

I don't need ProFTPD, but I'm courious what goes wrong here. Does anyone has any idea?
tedvg
 
Posts: 2
Joined: 20. June 2016 15:40
XAMPP version: 5.6.21
Operating System: Ubuntu 16.04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests