MySQL do not start at boot time

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySQL do not start at boot time

Postby aferweb2016 » 01. March 2016 09:52

Hi,
I installed the new XAMPP for Linux 5.6.15-2.
Everything works fine, but with one problem:
I want to start XAMPP automatically after boot, so I did what writes to your Xampp FAQs:


sudo ln -s /opt/lampp/lampp /etc/init.d/lampp
sudo chkconfig --add lampp
(I run CentOS 7)

After reboot Apache and ProFTP start, but MySQL do not.
Here is systemctl report:


systemctl status lampp.service
● lampp.service - LSB: XAMPP
Loaded: loaded (/etc/rc.d/init.d/lampp)
Active: active (running) since Tue 2016-03-01 10:12:18 EET; 7min ago
Docs: man:systemd-sysv-generator(8)
Process: 1477 ExecStart=/etc/rc.d/init.d/lampp start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/lampp.service
├─2820 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log ...
├─2836 proftpd: (accepting connections)
├─2993 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log ...
├─2994 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log ...
├─2995 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log ...
├─2996 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log ...
├─2997 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log ...
└─2998 /opt/lampp/bin/httpd -k start -E /opt/lampp/logs/error_log ...
Mar 01 10:12:11 localhost.localdomain systemd[1]: Starting LSB: XAMPP...
Mar 01 10:12:16 localhost.localdomain lampp[1477]: Starting XAMPP for Linux 5...
Mar 01 10:12:18 localhost.localdomain lampp[1477]: XAMPP: Starting Apache...ok.
Mar 01 10:12:18 localhost.localdomain lampp[1477]: XAMPP: Starting MySQL...ok.
Mar 01 10:12:18 localhost.localdomain lampp[1477]: XAMPP: Starting ProFTPD...ok.
Mar 01 10:12:18 localhost.localdomain proftpd[2836]: localhost - ProFTPD 1.3....
Mar 01 10:12:18 localhost.localdomain systemd[1]: Started LSB: XAMPP.

But the real status is:

/opt/lampp/lampp status
Version: XAMPP for Linux 5.6.15-2
Apache is running.
MySQL is not running.
ProFTPD is running.

This problem has appeared to latest version.
If I write the command:


sudo /opt/lampp/lampp startmysql
[sudo] password for xxxxxxxx:
XAMPP: Starting MySQL...ok.

Now MySQL starts ok. But not at boot time.
How can I fix it?


Regards,
aferweb2016
 
Posts: 3
Joined: 01. March 2016 09:27
Operating System: CentOS

Re: MySQL do not start at boot time

Postby aferweb2016 » 03. March 2016 19:18

Anyone, any sugestion?
aferweb2016
 
Posts: 3
Joined: 01. March 2016 09:27
Operating System: CentOS

Re: MySQL do not start at boot time

Postby aferweb2016 » 20. March 2016 12:17

It is someone who has the same problem with XAMPP on CentOS (mysql does not start automatically after restart) ?
aferweb2016
 
Posts: 3
Joined: 01. March 2016 09:27
Operating System: CentOS


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests