Version 7.0.3.0 - always_populate_raw_post_data=-1

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Version 7.0.3.0 - always_populate_raw_post_data=-1

Postby alcsantiago » 26. February 2016 19:07

Hi guys,

I have a problem with XAMPP 7.0.3.0 for Linux 64 bits.
I'm trying to install Zabbix on it, but I get a error message informing: PHP option "always_populate_raw_post_data" must be set to "-1"
I edit the php.ini file but I get the same message.
This line comes commented and I uncomment it, change the parameter for -1, stop the lampp service and start it again.

On XAMPP 5.6.15 for Linux 64 bits I didn't get the same result, everything ok, but in the new version.....this bug!

Can anyone help me to solve this problem here?
alcsantiago
 
Posts: 3
Joined: 03. January 2012 13:31
Operating System: Slackware 13.37

Re: Version 7.0.3.0 - always_populate_raw_post_data=-1

Postby Altrea » 26. February 2016 21:55

Hi,

According to the PHP Manual (http://php.net/manual/de/ini.core.php#ini.always-populate-raw-post-data) this setting is removed in PHP 7.
So i would guess this software is not PHP 7 compatible.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Version 7.0.3.0 - always_populate_raw_post_data=-1

Postby alcsantiago » 29. February 2016 13:33

[Solved]
I did as someone said in this topic:
https://www.zabbix.com/forum/showthread.php?t=49399
alcsantiago
 
Posts: 3
Joined: 03. January 2012 13:31
Operating System: Slackware 13.37


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests