XAMPP 5.6.15-1 and apache2 not compile with --with-pcre

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP 5.6.15-1 and apache2 not compile with --with-pcre

Postby alain.roger » 20. February 2016 22:37

Hi,

i'm facing an interesting topic. I installed latest version of XAMPP on ubuntu 15 and i got the following error message installing Wordpress CMS for development purpose.
Code: Select all
WordPress database error: [Got error 'this version of PCRE is compiled without UTF support at offset 0' from regexp]
DELETE FROM wp_options WHERE option_name REGEXP '^rss_[0-9a-f]{32}(_ts)?$'


after searching on internet i found that --with-pcre is not used as option with compiling apache2.
I found a config.nice in /opt/lampp folder where it is written "--with-pcre=/opt/lampp" as option so now i'm confused.
especially when a phpino() page displays such information:
Image

Is this version of apache 2.4 compiled with this option or not ?

thx
What does not kill you, makes you stronger

RogTek, Web agency: htttp://www.rogtek.com
facebook: http://www.facebook.com/rogtek
User avatar
alain.roger
 
Posts: 13
Joined: 03. February 2012 22:14
Operating System: Kubuntu 15.10

Re: XAMPP 5.6.15-1 and apache2 not compile with --with-pcre

Postby agnemedia » 04. April 2016 14:28

Did you find solution to fix this? (it si critical?)
WordPress database error: [Got error 'this version of PCRE is compiled without UTF support at offset 0' from regexp]
PHP Version 5.6.19
Darwin MacBook.local 15.4.0 Darwin Kernel Version 15.4.0: Fri Feb 26 22:08:05 PST 2016; root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64
agnemedia
 
Posts: 5
Joined: 21. December 2015 22:31
Operating System: Mac


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests