I can't add any tables to my database

Problems with the Linux version of XAMPP, questions, comments, and anything related.

I can't add any tables to my database

Postby rwob » 19. November 2015 23:05

I recently installed xampp on a linux server and edited my httpd-xampp.conf file to allow me access to the phpmyadmin page then rebooted the server and started xampp. I was able to create a database in phpmyadmin. Yet when I go to the database tab to click on the database I just get a yellow box that says "Loading..." that never disappears.

When I right click the database name from the left menu and say 'open link in new tab, I get this error page

SELECT `comment`
FROM `phpmyadmin`.`pma__column_info`
WHERE db_name = 'contacts'
AND table_name = ''
AND column_name = '(db_comment)'
MySQL said: Documentation

#1932 - Table 'phpmyadmin.pma__column_info' doesn't exist in engine

When I click the check mark next to the database and then go to the sql tab to write a create table query, it gives me the error "No database selected".

What steps do I need to take so that I can add a table and entries to that table in the database I just created?
rwob
 
Posts: 1
Joined: 17. November 2015 22:30
Operating System: Linux

Re: I can't add any tables to my database

Postby seigeeh » 18. December 2015 08:26

Same problem.
seigeeh
 
Posts: 1
Joined: 18. December 2015 07:59
Operating System: Linux

Re: I can't add any tables to my database

Postby Altrea » 18. December 2015 09:39

Try out the most recent XAMPP release
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests