Page 1 of 1

Permision Denied when opening localhost

PostPosted: 29. August 2004 20:07
by gomj0001
Whenever i try to open either locla host or anyfile i have uploaded to htdocs i get a permission denied error this on i get when openeing just local host

Warning: file_get_contents(lang.tmp) [function.file-get-contents]: failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/index.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/index.php:2) in /opt/lampp/htdocs/xampp/index.php on line 4

can anyone help me?

PostPosted: 28. December 2004 12:24
by Antho
Me too

Please help me

PostPosted: 28. December 2004 14:35
by Kristian Marcroft

which Browser are you using?
please try another one...
Mozilla/firebird etc. should work.

So long

PostPosted: 28. December 2004 14:49
by Antho
No I use Mozilla Firefox

PostPosted: 28. December 2004 15:09
by Wiedmann
Follow the readme step by step (exact!) when you install/extract XAMPP.

PostPosted: 28. December 2004 16:58
by Antho
when i start xampp,
this message show : A FTP daemon is already running.
but no ftp running on my pc

sorry for my bad english but i'm french

PostPosted: 28. December 2004 17:09
by Kristian Marcroft

are you sure?
Most FTPds are started via inetd/xinetd
Check /etc/inetd.conf and /etc/xinetd.conf

So long

PostPosted: 28. December 2004 18:48
by Antho
Now, there is no erropr message when I start xampp
but the permission denied show again
I read the readme, all is correct



PostPosted: 03. January 2005 21:37
by xxrsc
Same issue here. XAMPP starts fine. I've tried from Konqueror and IE from another machine on the network. I get the same error. Is it a permissions issue with PHP?

PostPosted: 03. January 2005 21:48
by xxrsc
Fixed it. Give read permission to the lang.tmp file.

i have xampp instald on debian, and http://localhost is not.

PostPosted: 06. January 2005 13:42
by gorgo
i am new to this, and this is my first install of xampp

http://localhost gives me:
the connection was refused wen attemting to contact localhost

i set the fire-wall off.
my internet connection is good, static ip, gateway..
and even the smb serves shows in my xp box.
"Fixed it. Give read permission to the lang.tmp file"=
i cant find the lang.tmp file,

thanks for reading

PostPosted: 06. January 2005 15:39
by Kristian Marcroft

did you start XAMPP?

So long

yes its running, i have a hole list in my gateway with: loca

PostPosted: 08. January 2005 15:37
by gorgo
yes its running, i have a hole list in my gateway with: localhost not fount,
is this it? the trubble is i dont wana start a studie debian, just work on the sql.
wat is the best disto for xampp?
idear?, a xampp distro, like clarkconnect.

i still have :"the connection was refusd when attemping to contact localhost"

when starting it gives me ftp deamon allready running.


PostPosted: 09. January 2005 13:27
by BlackbirdHakke
Hi there,

this helped me (on Debian) with xampp:
In httpd.conf:
#ScoreBoardFile logs/apache_runtime_status
and edit to:
ScoreBoardFile logs/apache_runtime_status
as written in the FAQ.
Give it a try, this stopped my "the connection was refusd when attemping to contact localhost" error and startet xampp correctly.

greets, Flo