MySQL problem

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySQL problem

Postby Harpist » 01. September 2015 17:16

Hi folks,

For the past three years, I have hosted a website using XAMPP 1.8.3-1 with Ubuntu 13.10. However, my computer locked up last week and when I went in to troubleshoot, I found that the hard drive had been filled up with log files. I deleted the log files and made some changes to keep it from happening again. Then the fun began.

I then stopped the LAMPP services that got started automatically:

sudo /opt/lampp/lampp stop

It looked loke everything stopped OK. Then I restarted LAMPP:

sudo /opt/lampp/lampp start

Apacher and ProFTPD restarted fine, but trying to restart MySQL:

Starting MySQL.....already running.

Then I opened Firefox and ran phpinfo.php and everything looked good. I then ran phpMyAdmin and I got the following error message:

#2002 connwction refused
The server is not responding (or the local server's socket is not correctly configured)
Connection for controluser as defined in your configuration failed


I also tried my Joomla website and received an error

Database error: Unable to connect to the database

Any and all assistance is welcome. I am not particularly linux savey but can usually figure things out. This one has me stumped.

Good Roads

Harpist
Harpist
 
Posts: 15
Joined: 30. June 2011 19:40
Operating System: WinXP Professional Ver2002 SP3

Re: MySQL problem

Postby Nobbie » 01. September 2015 18:36

Sorry, but there is not even one hint, what is going wrong. Nothing. You definately have to go deeper into that, look for other MySQL instances for example etc., take a look at the process table ("sudo ps -fe") etc., but without anything we cannot help you.
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04

Re: MySQL problem

Postby Harpist » 01. September 2015 21:58

Hi folks,

I got it running by the following commands:

sudo /opt/lampp/sbin/mysqld stop
sudo /opt/lampp/sbin/mysql
sudo /opt/lampp/lampp stop
sudo /opt/lampp/lampp start

I'm guessing that some of this was superfluous (as the Swedes would say "cake on cake"), but it got it working.

Good Roads

Harpist
Harpist
 
Posts: 15
Joined: 30. June 2011 19:40
Operating System: WinXP Professional Ver2002 SP3


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests