Backups don't work

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Backups don't work

Postby Repute » 22. August 2004 23:06

when i try to restore the backups after a new install I get the following errors:

tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
Checking integrity of files...
egrep: md5sums: No such file or directory
Restoring configuration, log and htdocs files...
tar: Skipping to next header
tar: Archive contains obsolescent base-64 headers

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error exit delayed from previous errors
Checking versions...
cat: VERSION: No such file or directory
Installed: XAMPP 1.4.5
Backup from: XAMPP
The backup sofware is not able to handle different XAMPP versions.
Your backuped configuration from may not work with 1.4.5 and may need manually corrections.
XAMPP: Do you want to continue [no] y
Let's try...
Restoring MySQL databases...
xampp-backup-22-08-04.sh: line 129: *.sql: No such file or directory
* FAILED: cat: output: No such file or directory
Restoring MySQL user databases...
xampp-backup-22-08-04.sh: line 138: mysql.sql: No such file or directory
MySQL user FAILED: cat: output: No such file or directory




What is the problem please help coase I desperetly need to get this working otherwise I have a big problem :S

Greets,

Repute
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Repute » 23. August 2004 12:13

Please help me!
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 23. August 2004 14:10

Dear Repute!

Your backup file seems to be corrupt: tar: Unexpected EOF in archive.

How big is your backup file? Is it big as it should be big (according to the backuped data)?

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Repute » 23. August 2004 15:23

Jep it's 380 mb big, and I 1st backed it up on my Windows Xp machine.
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby MinJun » 23. August 2004 16:15

I'm not really firm in handling with tar archives but I found a workaround for repairing damaged tar archives:
http://www.bestsolution.at/support/cons ... hives.html

Maybe this could help you to rescue most of your data.

Good Luck :wink:
Pampa: Grast du noch oder ziehst du um?!?
User avatar
MinJun
 
Posts: 29
Joined: 08. December 2003 08:06
Location: grazing in the pampa ;-)

Postby Oswald » 23. August 2004 17:52

Dear Repute!

380 MBs? That's much. Do you've enough disk space free to extract the backup?

What is the output of the following command:

head -150 xampp-backup-22-08-04.sh | tail -1

And the output of this command:

tail +151 xampp-backup-22-08-04.sh | tar tvfz -

(Please make sure to call the commands from the same directory where your backup files is stored)

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Repute » 23. August 2004 18:28

Thnx for trieng to help me out!

I have enough room I have 50 gig free right now...

These are the results:

[root@repute backup]# head -150 xampp-backup-22-08-04.sh | tail -1
##BACKUPDATA##


[root@repute backup]# tail +151 xampp-backup-22-08-04.sh | tar tvfz -
-rw-r--r-- root/root 339349164 2004-08-22 13:01:05 data.tar.gz

gzip: stdin: invalid compressed data--format violated
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now


By the way thanx for the link MinJun but that didn't work out :S
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 23. August 2004 23:01

Dear Repute!

Looks like my first assumption was right: the tar archive of the backup is corrupt. :( Can you copy the file from the Windows machine again to your Linux system? May be something got wrong while copying.

If that doesn't help you may try the hint from MinJun: First you need to extract the tar archive from the XAMPP backup file with the following command:

tail +151 xampp-backup-22-08-04.sh > tar-from-backup.tar.gz

Now follow the instructions from the link MinJun posted.

Good luck!!
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Repute » 24. August 2004 11:44

Nope dos'nt work thnx for all your help!
Going to install from scratch now :cry:
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests