Enabling XSL Support?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Enabling XSL Support?

Postby dpasacritacrown » 28. April 2015 18:54

Hi everyone, we're looking to try out Symphony, an open source CMS, and we were looking into using XAMPP with it, as it includes all of the dependencies. Symphony requires this however:

PHP 5.3 or above
PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
MySQL 5.0 or above
An Apache or Litespeed webserver
Apache's mod_rewrite module or equivalent

Is there any way to have XAMPP install PHP with the --with-xsl flag on it?

We're installing this on Centos 7.
dpasacritacrown
 
Posts: 1
Joined: 28. April 2015 18:46
Operating System: Centos 7

Re: Enabling XSL Support?

Postby Nobbie » 28. April 2015 22:12

Why Xampp? You cannot install a different PHP version than the delivered version. If PHP is not compiled with --with-xsl, you cannot change that.

Usually all linux distributions offer a fully featered LAMP environment, which mostly is superior to Xampp in any way. Its fully flexible and you may even compile it from scratch.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests