Please help - Trouble creating new virtual site

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Please help - Trouble creating new virtual site

Postby djpackman » 19. March 2015 22:40

I'm attempting to create a new virtual site based on a site that was created by a different developer that is no longer with the company. I have taken the following steps:
1. Reviewed the httpd.conf file. The virtual host configurations are stored in /srv/websites/conf/enabled

# Include the virtual host configurations:
Include /srv/websites/conf/enabled/*.conf
ServerName elmirapet.com

2. Copied one .conf file to a different one with a new name
cp -rp /srv/websites/conf/enabled/site1.conf /srv/websites/conf/enabled/site2.conf

3. Modified site2.conf as follows:
DocumentRoot /srv/websites/site2/wwwroot
Servername site2.company.com
<Directory "/srv/websites/site2.companyn.com/wwwroot">

4. Copied the existing site directory to the new site
cp -rp /srv/websites/site1 /srv/websites/site2

5. Restarted Apache sudo service httpd restart

The new website will not open in a web browser http:/site2.company.com - I only get a "this page cannot be displayed".

Can you point me in the right direction? What step(s) am I missing?

Thanks,

-Dan
djpackman
 
Posts: 1
Joined: 19. March 2015 22:27
Operating System: Red Hat

Re: Please help - Trouble creating new virtual site

Postby Nobbie » 20. March 2015 13:08

djpackman wrote:Can you point me in the right direction? What step(s) am I missing?


You are missing a slash:

http://site2.company.com
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests