xampp with another version of php

Problems with the Linux version of XAMPP, questions, comments, and anything related.

xampp with another version of php

Postby mirko78 » 04. January 2015 12:03

I need to install xampp e I need php 5.3.10 versione... on ubuntu 14.04
How I can do it?
thanks
mirko78
 
Posts: 3
Joined: 04. January 2015 11:58
Operating System: ubuntu 14.04

Re: xampp with another version of php

Postby Nobbie » 04. January 2015 13:09

Use an older Xampp which includes PHP 5.3.1 (you will find all versions on sourceforge).
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: xampp with another version of php

Postby mirko78 » 04. January 2015 23:27

I visit this site:
http://code.stephenmorley.org/articles/xampp-version-history-apache-mysql-php/

It's seem that not exists Xaamp version with php 5.3.10 or...5.3.20 (also this version it's ok for me)
I dont want 5.3.1 but i need 5.3.10..
thank you
mirko78
 
Posts: 3
Joined: 04. January 2015 11:58
Operating System: ubuntu 14.04

Re: xampp with another version of php

Postby Altrea » 05. January 2015 01:48

Use XAMPP 1.7.7 which comes with PHP 5.3.8.
That is as near as you can get to PHP 5.3.10
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp with another version of php

Postby mirko78 » 06. January 2015 08:50

there is not any way to use 5.10 (...5.29...5.30) with xampp?
Can I use Xamp only with the version in this table (http://code.stephenmorley.org/articles/xampp-version-history-apache-mysql-php)?)
Can I not use xampp with other versions?
thank you
mirko78
 
Posts: 3
Joined: 04. January 2015 11:58
Operating System: ubuntu 14.04

Re: xampp with another version of php

Postby Nobbie » 06. January 2015 12:12

mirko78 wrote:there is not any way to use 5.10 (...5.29...5.30) with xampp?


No.

mirko78 wrote:Can I use Xamp only with the version in this table (http://code.stephenmorley.org/articles/ ... -mysql-php)?)


Yes.

mirko78 wrote:Can I not use xampp with other versions?



No. It may be possible to replace PHP in an existing Xampp environment, but requires lot of knowledge and it is not recommended. But the differences between all these PHP versions are very, very, very, very small. Mostly only some bug fixes or similar. Not really a different PHP. I dont think that you really need exactly PHP 5.10 for your development.

What is the goal of your project?
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: xampp with another version of php

Postby lch » 11. June 2015 19:44

but drush is not available for 4.43?
lch
 
Posts: 8
Joined: 04. June 2015 19:14
Operating System: linux mint 13 mate desktop

Re: xampp with another version of php

Postby Nobbie » 11. June 2015 21:23

Ask drush.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: xampp with another version of php

Postby glitzi85 » 12. June 2015 13:52

According to this site: http://docs.drush.org/en/master/install/ it requires any version above 5.3.0
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests