Error when running Duplicator installer.php file

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error when running Duplicator installer.php file

Postby codeyoda » 18. December 2014 19:35

Hi,

I am running XAMPP on an Ubuntu 14.04 distribution. Everything working fine. I am trying to duplicate a live site onto my local server using the duplicator plugin for WordPress.

I have downloaded and copied the installer.php file and the zip file from the duplicator plugin to my local project file. I then navigate to the local installer.php file within my browser:

http://localhost/sites/testsite.com/installer.php

Instead of the installer script running I get the following error message:

Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

Fatal error: Unknown: Failed opening required '/opt/lampp/htdocs/sites/testsite.com/installer.php' (include_path='.:/opt/lampp/lib/php') in Unknown on line 0


I am not sure what this means and what the solution would be? Any help is much appreciated.

Thanks, Regards

Ross
codeyoda
 
Posts: 1
Joined: 18. December 2014 19:10
Operating System: Linux Ubuntu 14.04

Re: Error when running Duplicator installer.php file

Postby Nobbie » 19. December 2014 20:46

As you wont get any hint here (because this is the Xampp Linux board), i recommend to go to WordPress and ask there. I dont know Wordpress, i dont know installer.php, i dont know anything about these things.
Nobbie
 
Posts: 9760
Joined: 09. March 2008 13:04

Re: Error when running Duplicator installer.php file

Postby 4C's Media » 10. October 2017 14:15

check your permissions on the /sites/ folder.
Right click, select Get Info
Click on the little lock icon on the right hand bottom and login as admin
then you can change the permissions on the folder.

Hope this helps.

Kind Regards,
Robert
User avatar
4C's Media
 
Posts: 2
Joined: 10. October 2017 10:44
XAMPP version: 7.1.9-0
Operating System: MacOS

Re: Error when running Duplicator installer.php file

Postby Nobbie » 10. October 2017 19:26

4C's Media wrote:Hope this helps.


Three years(!) later?
Nobbie
 
Posts: 9760
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests