Apache doesn't start

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Apache doesn't start

Postby aurquiel » 05. November 2014 19:55

Hello

I get a issue trying to start apache, well i always go to console for start xampp.

It's given this issue

Code: Select all
bjt@bjt-VPCCA17FL ~ $ sudo /opt/lampp/lampp start
Starting XAMPP for Linux 1.8.3-5...
XAMPP: Starting Apache...fail.
XAMPP:  Starting diagnose...
XAMPP:  Sorry, I've no idea what's going wrong.
XAMPP:  Please contact our forum http://www.apachefriends.org/f/
Last 10 lines of "/opt/lampp/logs/error_log":
tail: no se puede abrir «/opt/lampp/logs/error.log» para lectura: No existe el archivo o el directorio
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.


So i opened error_log

Code: Select all
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
Then i looked for all programs that was using port 80
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs


Then i looked for all programs that was using port 80

Code: Select all
lsof -i tcp:80


This was the result

Code: Select all
COMMAND   PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
firefox 19613  bjt   44u  IPv4 314893      0t0  TCP 192.168.0.121:54519->stackoverflow.com:http (ESTABLISHED)
firefox 19613  bjt   60u  IPv4 314918      0t0  TCP 192.168.0.121:60160->qa-in-f95.1e100.net:http (ESTABLISHED)
firefox 19613  bjt   69u  IPv4 314921      0t0  TCP 192.168.0.121:48196->cf-190-93-247-58.cloudflare.com:http (ESTABLISHED)
firefox 19613  bjt   70u  IPv4 314925      0t0  TCP 192.168.0.121:48197->cf-190-93-247-58.cloudflare.com:http (ESTABLISHED)


it shows only firefox ussing that port, i dont know what to do?
aurquiel
 
Posts: 4
Joined: 25. February 2014 19:36
Operating System: linuxmint

Re: Apache doesn't start

Postby Nobbie » 05. November 2014 21:55

aurquiel wrote:Then i looked for all programs that was using port 80


Why that???

Each(!) message complaints against port 443, none(!) of them against port 80, but you looked for programs using port 80? Funny or crazy??
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache doesn't start

Postby aurquiel » 06. November 2014 02:16

I got the same issue in that port 443

This are the programs ussing that port

Code: Select all
COMMAND  PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
firefox 4494  bjt   59u  IPv4  45795      0t0  TCP 192.168.0.121:47916->iad23s07-in-f30.1e100.net:https (ESTABLISHED)
firefox 4494  bjt  117u  IPv4  28974      0t0  TCP 192.168.0.121:38202->199.16.158.81:https (ESTABLISHED)
aurquiel
 
Posts: 4
Joined: 25. February 2014 19:36
Operating System: linuxmint

Re: Apache doesn't start

Postby Nobbie » 06. November 2014 11:18

I think, you either have an active firewall or you have already an Apache Service running on your system. lsof is not the appropriate tool to find that out.

Instead use "netstat" and/or "ps" to find out, which process may lock port 80 (and/or 443):

Enter

Code: Select all
sudo netstat -tulpn | grep :80


in a terminal. If any output occurs, the last token in the line tells you process ID and process name, which is using port 80 (you may run the same command again with 443 instead of 80). The output may look so:

Code: Select all
tcp6       0      0 :::80                   :::*                    LISTEN      23492/httpd


(This is the output from my Ubuntu Linux running Xampp).

The last token shows the Process ID 23492 and the name httpd (this is the Apache Server, on some machines it is called apache or apache2 instead).

You the may filter the process list for this ID:

Code: Select all
sudo ps -fe | grep 23492


This may show a number of active instances of httpd. Of course you may skip netstat and may look for httpd of apache immediately (use -i option for case insensitive):

Code: Select all
sudo ps -fe | grep -i http


or

Code: Select all
sudo ps -fe | grep -i apache


If no process is listed, you should go further for a firewall. But i think, that it is an Apache which already comes with your distribution. If you like to run Xampps Apache instead, you have to stop that system Apache at least (you may also de-install it, as you dont need it) and then try to run Xampp again.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache doesn't start

Postby aurquiel » 07. November 2014 22:41

No, i don't have apache2 installed in my unix system

i got this

Code: Select all
sudo netstat -tulpn | grep :443

tcp        0      0 0.0.0.0:443             0.0.0.0:*               ESCUCHAR    3311/vmware-hostd
tcp6       0      0 :::443                  :::*                    ESCUCHAR    3311/vmware-hostd


Vmware is a program to run a virtual machine, i think this is the program who interferes with xampp, but i don't wanna to uninstall it.

Let my see if there an option for change that port

I resolved it, change the preferences of VMware station :) Thanks a lot
aurquiel
 
Posts: 4
Joined: 25. February 2014 19:36
Operating System: linuxmint

Re: Apache doesn't start

Postby david.ibhaluobe » 15. November 2014 23:32

I have a similar issue i just install XAMPP. I am a php beginner. MYSQL database is running, ProFTDP is running but Appache web server is not returning. if i try to start it, it fails.
I am using Ubuntu 12.04LTS as Operating System. I install XAMPP 1.8.3-5 version.

This is the message i got on my Mozilla Firefox browser when i typed locahost:
It works!
This is the default web page for this server.
The web server software is running but no content has been added, yet.


please what can i do to get Apache web server running?

I typed this command on my terminal: sudo ps -fe | grep 23492 . this is the following result:

david 8725 8604 0 23:11 pts/1 00:00:00 grep --color=auto 23492

I typed this command on my terminal: sudo ps -fe | grep -i http . this is the following result:

david 8804 8604 0 23:12 pts/1 00:00:00 grep --color=auto -i http
david 26019 1 0 Nov09 ? 00:00:00 /usr/lib/gvfs/gvfsd-http --spawner :1.4 /org/gtk/gvfs/exec_spaw/2
root 32593 1 0 22:14 ? 00:00:00 /bin/sh /usr/bin/xdg-open http://bitnami.com/stack/xampp?utm_source=bitnami&utm_medium=installer&utm_campaign=XAMPP%2BInstaller
root 32659 32593 4 22:14 ? 00:02:40 /usr/lib/firefox/firefox http://bitnami.com/stack/xampp?utm_source=bitnami&utm_medium=installer&utm_campaign=XAMPP%2BInstaller


I typed this command on my terminal: sudo ps -fe | grep -i apache . this is the following result:

root 1209 1 0 Nov02 ? 00:00:31 /usr/sbin/apache2 -k start
david 9020 8604 0 23:16 pts/1 00:00:00 grep --color=auto -i apache
www-data 23983 1209 0 Nov09 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 24007 1209 0 Nov09 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 24008 1209 0 Nov09 ? 00:00:00 /usr/sbin/apache2 -k start
david.ibhaluobe
 
Posts: 2
Joined: 15. November 2014 22:49
Operating System: Ubuntu 12.04LTS

Re: Apache doesn't start

Postby Nobbie » 16. November 2014 00:13

david.ibhaluobe wrote:I typed this command on my terminal: sudo ps -fe | grep -i apache . this is the following result:

root 1209 1 0 Nov02 ? 00:00:31 /usr/sbin/apache2 -k start
david 9020 8604 0 23:16 pts/1 00:00:00 grep --color=auto -i apache
www-data 23983 1209 0 Nov09 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 24007 1209 0 Nov09 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 24008 1209 0 Nov09 ? 00:00:00 /usr/sbin/apache2 -k start


Obviously you already have installed another instance of Apache, which causes the collision with the Apache coming with Xampp. If you like to use Xampps Apache, you simply should deinstall this Apache with the help of the Ubuntu Software Center.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache doesn't start

Postby david.ibhaluobe » 18. November 2014 18:25

Thanks a lot.
david.ibhaluobe
 
Posts: 2
Joined: 15. November 2014 22:49
Operating System: Ubuntu 12.04LTS

Re: Apache doesn't start

Postby bf_jeje » 19. January 2015 05:18

Hi. I've got a very similar result using the commands above:
sudo ps -fe | grep -i apache2
root 8746 1895 0 00:27 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 8979 8746 0 00:28 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 8980 8746 0 00:28 ? 00:00:00 /usr/sbin/apache2 -k start
bruno 18404 14205 0 01:09 pts/0 00:00:00 grep --color=auto -i apache2

I want to uninstall the other instance of apache, but i have no idea what programs i have installed in my computer (i've started with linux recently)

any example of programs that could cause that inconvenient? or a way i could figure out what's the annoying program?
bf_jeje
 
Posts: 1
Joined: 19. January 2015 05:14
Operating System: Ubuntu 14.04

Re: Apache doesn't start

Postby Nobbie » 19. January 2015 12:15

Start the "Ubuntu Software-Center" and click on the "Installed" Button in the top menu. You get a menu like a start menu and you can browse thru all the installed software on your PC. There is also a search field in the upper right, you may try to enter "apache" there. If you click on any software product, you get the option to install or de-install it.

I wonder how you managed to install Apache via Ubuntu, because i am running exactly the same Ubuntu Version (Desktop Version Ubuntu 14.04) and there is no Apache pre-installed. Anyway, the Ubuntu Software-Center should help you out of that.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests