MySql database status shows DEACTIVATED

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySql database status shows DEACTIVATED

Postby adetheheat » 15. September 2014 14:29

Running ubuntu linux 14.04.1 and xamppp 1.8.3-5.

I can start everything up with lampp start. It says:
XAMPP:Starting apache ...ok
XAMPP:Starting MYSQL ...ok
XAMPP:Starting ProFTPD ...ok

Then when I go to firefox localhost/xampp->Status it says
MySQL database Deactivated
PHP Activated
Perl Activated
Common Gateway Activated
Server Side Includes Activated

Other replies to similar posts say to go to htdocs/xampp/mysql.php and change the line in there from mysql_connect to mysqli_connect
After doing this and restart xampp it still says deactivated.

(also i have another thread about not being able to access phpmyadmin option from the xampp main web page).

All in all this is making using xampp for linux very difficult indeed. I have started from scratch with new linux and new xampp but can't get past these issues which means I can't do any work.
Why can't this just work out of the box like it does for windows ??
Posts: 8
Joined: 11. June 2014 15:02
Operating System: Linux

Re: MySql database status shows DEACTIVATED

Postby RSmithBothell » 25. September 2014 01:38

I'm having the same problem.
It worked last week.
my php script just shows the contents of the php file the html file refers to.

No other mysqld running.
All is fine, BUT this issue.

Can use phpMyAdmin no problem.

What can we do???


FROM properties.ini

websmiths-mbp:xamppfiles root# more properties.ini
mysql_arguments=-u root -S "/Applications/XAMPP/xamppfiles/var/mysql/mysql.sock"

FROM logs/error.log

[Wed Sep 24 16:45:47.844434 2014] [ssl:warn] [pid 31186] AH01906: server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Sep 24 16:45:47.844834 2014] [ssl:warn] [pid 31186] AH01909: server certificate does NOT include an ID which matches the server name
[Wed Sep 24 16:45:47.845183 2014] [suexec:notice] [pid 31186] AH01232: suEXEC mechanism enabled (wrapper: /Applications/XAMPP/xamppfiles/bin/suexec)
[Wed Sep 24 16:45:48.087098 2014] [lbmethod_heartbeat:notice] [pid 31187] AH02282: No slotmem from mod_heartmonitor
[Wed Sep 24 16:45:49.000270 2014] [auth_digest:notice] [pid 31187] AH01757: generating secret for digest authentication ...
[Wed Sep 24 16:45:49.013332 2014] [ssl:warn] [pid 31187] AH01906: server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Sep 24 16:45:49.013379 2014] [ssl:warn] [pid 31187] AH01909: server certificate does NOT include an ID which matches the server name
[Wed Sep 24 16:45:49.016493 2014] [mpm_prefork:notice] [pid 31187] AH00163: Apache/2.4.9 (Unix) PHP/5.4.27 OpenSSL/1.0.1g mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
[Wed Sep 24 16:45:49.016576 2014] [core:notice] [pid 31187] AH00094: Command line: '/Applications/XAMPP/xamppfiles/bin/httpd -E /Applications/XAMPP/xamppfiles/logs/error_log -D SSL -D PHP'


FROM var/mysql/myhostname.local.err

140924 16:45:53 mysqld_safe Starting mysqld daemon with databases from /Applications/XAMPP/xamppfiles/var/mysql
140924 16:45:53 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
140924 16:45:53 [Warning] Setting lower_case_table_names=2 because file system for /Applications/XAMPP/xamppfiles/var/mysql/ is case insensitive
140924 16:45:53 [Note] Plugin 'FEDERATED' is disabled.
140924 16:45:53 InnoDB: The InnoDB memory heap is disabled
140924 16:45:53 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140924 16:45:53 InnoDB: Compressed tables use zlib 1.2.8
140924 16:45:53 InnoDB: Initializing buffer pool, size = 16.0M
140924 16:45:53 InnoDB: Completed initialization of buffer pool
140924 16:45:53 InnoDB: highest supported file format is Barracuda.
140924 16:45:53 InnoDB: Waiting for the background threads to start
140924 16:45:54 InnoDB: 5.5.36 started; log sequence number 1819521
140924 16:45:54 [Note] Server hostname (bind-address): ''; port: 3306
140924 16:45:54 [Note] - '' resolves to '';
140924 16:45:54 [Note] Server socket created on IP: ''.
140924 16:45:54 [Note] Event Scheduler: Loaded 0 events
140924 16:45:54 [Note] /Applications/XAMPP/xamppfiles/sbin/mysqld: ready for connections.
Version: '5.5.36' socket: '/Applications/XAMPP/xamppfiles/var/mysql/mysql.sock' port: 3306 Source distribution
Posts: 3
Joined: 25. September 2014 01:35
Operating System: OS X 10.8 and it's 1.8.2-5

Re: MySql database status shows DEACTIVATED

Postby Nobbie » 25. September 2014 12:31

According to the pathnames in your protocoll, you are working on a MAC with OSX. Therefore you asked in the wrong board, this is the LINUX board, the OSX board is on step beyond.
Posts: 8634
Joined: 09. March 2008 13:04

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests