Access forbidden under ElementaryOS using VirtualHost

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Access forbidden under ElementaryOS using VirtualHost

Postby kabeza » 23. April 2014 23:19

I removed lamp from my ElementaryOS install because I was getting mad trying to fix 403 error.
I installed xampp successfuly, then changed config and added a new virtualhost, etc. All was fine till here

Then, I begun copying files again, etc. and when I run the url file again, got the same error :x
Access Forbidden


I have a little shell I execute when copying files to my /home/me/www

Code: Select all
sudo find $SRCDIR -type f -exec chmod 755 {} \;
sudo find $SRCDIR -type d -exec chmod 775 {} \;
sudo find $SRCDIR -type d -exec chmod g+s {} \;

When I opened the myerrorvhostlog, I see the following. The css file cannot be accessed when called from login.php nor called directly in browser

Code: Select all
[Wed Apr 23 19:02:06.480529 2014] [access_compat:error] [pid 24059] [client] AH01797: client denied by server configuration: /home/kike/www/abril/application/views/tplcan/css/font-awesome.min.css, referer: http://localhost/abril/application/views/tplcan/css/font-awesome.min.css
[Wed Apr 23 19:07:33.877814 2014] [access_compat:error] [pid 28568] [client] AH01797: client denied by server configuration: /home/kike/www/abril/application/views/tplcan/css/font-awesome.min.css

And finally this is my vhost

Code: Select all
<VirtualHost *:80>
    ServerName localhost
    DocumentRoot "/home/kike/www"
    <Directory "home/kike/www">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order Allow,Deny
        Allow From All
        Require all granted
    ErrorLog "logs/kikewww-error_log"

Any ideas about how to fix this?
Thanks a lot in advance
User avatar
Posts: 2
Joined: 17. May 2011 13:28
Location: San Juan, Argentina

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests