new XAMPP install won't start Apache

Problems with the Linux version of XAMPP, questions, comments, and anything related.

new XAMPP install won't start Apache

Postby rpallen » 17. February 2014 14:46

I am using Linux Mint 16, xfce and I just downloaded and installed XAMPP 1.8.3. When I enter the command to start it, Apache fails to start, though MySQL and ProFTPD start fine. The computer returns a statement, "I've no idea what's going wrong."
I have no idea how to begin troubleshooting this. Can anyone help?
rpallen
 
Posts: 7
Joined: 17. February 2014 14:35
Operating System: Linux Mint 16 xfce

Re: new XAMPP install won't start Apache

Postby rpallen » 18. February 2014 11:01

I tried again today with the same result. I didn't notice yesterday, but further down was the message, "Last 10 lines of "/opt/lampp/logs/error_log":
tail: não foi possível abrir “/opt/lampp/logs/error.log” para leitura: Arquivo ou diretório não encontrado"

I don't know what "tail" means here, but the translation of the rest would be "not possible to open /opt/lampp/logs/error.log'' for reading: File or directory not found"
rpallen
 
Posts: 7
Joined: 17. February 2014 14:35
Operating System: Linux Mint 16 xfce

Re: new XAMPP install won't start Apache

Postby Nobbie » 18. February 2014 11:24

rpallen wrote:I don't know what "tail" means here,


This message is issued by the Shell, and "tail" is a standard linux program which shows the "tail" of a file (the last few lines). This error message means, that the program "tail" could not open the file /opt/lampp/logs/error.log (which would have opened and the last lines would have been shown).

Find out what is wrong with /opt/lampp/logs/error.log. On the first look i wonder, why it is "/opt/lampp/logs/error_log" in the message ("Last 10 lines of "/opt/lampp/logs/error_log":), but then /opt/lampp/logs/error.log in the error of tail.

Maybe you typed it wrong, maybe there is a typo in the startup script. In any case, find out which filename is the right one for the error log (either error.log or error_log) and try to read that file, in order to find out what happens to Apache.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: new XAMPP install won't start Apache

Postby rpallen » 18. February 2014 11:38

Thanks, Nobbie.
I went to the directory and found the error log. It has several copies of the same entry, perhaps because I tried to start it several times. That entry is:
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs

I really have no idea what this means. There are 3 other log files in the logs directory and they are all empty.
rpallen
 
Posts: 7
Joined: 17. February 2014 14:35
Operating System: Linux Mint 16 xfce

Re: new XAMPP install won't start Apache

Postby Nobbie » 18. February 2014 11:54

rpallen wrote:I really have no idea what this means


That message means, that Port 80 (which is used by Apache) is already in use by another process. You have to find out, which process causes this. Normally, there are only a few possibilities for that:

a) you have a skype installation up and running. Do you? If so, enter the Skype Options Menu and configure Skype NOT to use Port 80.

b) you already have an Apache installation up and running. Enter "ps -fe" in a shell (terminal) and watch out for "Apache", or "apache" (or "Apache2" or similar) or "httpd".

If you already have an Apache installation, go to the System Menu of Linux Mint and start the Software Installation tool and try to find the corresponding package, if you find it choose de-installation and finally reboot your PC. Then try again to start Xampp.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: new XAMPP install won't start Apache

Postby rpallen » 18. February 2014 12:48

OK, I uninstalled my Skype and tried again with the same result.
I entered "ps -fe" and got:
www-data 1401 1380 0 08:33 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 1402 1380 0 08:33 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 1403 1380 0 08:33 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 1404 1380 0 08:33 ? 00:00:00 /usr/sbin/apache2 -k start
www-data 1405 1380 0 08:33 ? 00:00:00 /usr/sbin/apache2 -k start

I'm not sure I really need to uninstall apache, I want to use it. I entered http://localhost into a browser on got a page the says, "It works!
This is the default web page for this server.
The web server software is running but no content has been added, yet."

I was expecting the XAMPP splash screen so I can access the tools. How can I access the tools? Will I have to uninstall the current apache and reinstall?
rpallen
 
Posts: 7
Joined: 17. February 2014 14:35
Operating System: Linux Mint 16 xfce

Re: new XAMPP install won't start Apache

Postby rpallen » 18. February 2014 12:53

YIKES. Just to see what would happen, I entered the stop command for XAMPP. I got messages that XAMPP was stopping but none of the other 3 programs were running.
Stopping XAMPP for Linux 1.8.3-2...
XAMPP: Stopping Apache...not running.
XAMPP: Stopping MySQL...not running.
XAMPP: Stopping ProFTPD...not running.

So I entered the start XAMPP command and got the usual
Starting XAMPP for Linux 1.8.3-2...
XAMPP: Starting Apache...fail.
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://www.apachefriends.org/f/
Last 10 lines of "/opt/lampp/logs/error_log":
tail: não foi possível abrir “/opt/lampp/logs/error.log” para leitura: Arquivo ou diretório não encontrado
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.

Now I'm really confused.
rpallen
 
Posts: 7
Joined: 17. February 2014 14:35
Operating System: Linux Mint 16 xfce

Re: new XAMPP install won't start Apache

Postby Nobbie » 18. February 2014 13:09

rpallen wrote:I'm not sure I really need to uninstall apache, I want to use it.


If you want to use Xampp, you have to uninstall this apache (Xampp comes with apache as well).

rpallen wrote:I was expecting the XAMPP splash screen so I can access the tools. How can I access the tools?


No, the Xampp tools are preconfigured for Xampps apache. So if you dont want to uninstall your apache, i cannot help you further. It is on you. If you are running the (linux mints) apache, you dont have the Xampp splash screen and even not the tools.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: new XAMPP install won't start Apache

Postby rpallen » 18. February 2014 13:25

OK, in the package manager I did a search for "apache".
I uninstalled all of the results.
I re-ran the installer I downloaded from apachefriends.org.
I am now able to start and stop apache, MySQL and ProFTPD.

But when I enter localhost in the browser, I still get "It works! This is the default web page for this server.The web server software is running but no content has been added, yet."

I don't know how to get to the splash screen or access the tools, for example, how do I get into MySQL?
rpallen
 
Posts: 7
Joined: 17. February 2014 14:35
Operating System: Linux Mint 16 xfce

RESOLVED Re: new XAMPP install won't start Apache

Postby rpallen » 18. February 2014 14:14

Thank you for all of your help Nobbie.
i read something else that lead me to clearing the cache and entering "localhost" again. And that was all that was needed to get to the splash screen. Pretty simple, but not so intuitive.

Well, anyway, thanks again for all of your help.
rpallen
 
Posts: 7
Joined: 17. February 2014 14:35
Operating System: Linux Mint 16 xfce

Re: new XAMPP install won't start Apache

Postby Net1 » 28. July 2014 13:49

Hi rpallen,

same problem here. Could you please share this other thing for clearing the cache and fix this issue?

Thanks in advance!
Soy el Jinete Nocturno q jamás volverá...
Net1
 
Posts: 1
Joined: 28. July 2014 13:38
Location: Night City
Operating System: Ubuntu Desktop 14.04

Re: new XAMPP install won't start Apache

Postby Nobbie » 29. July 2014 10:20

Net1 wrote:Could you please share this other thing for clearing the cache and fix this issue?


This means the browser cache. Enter the setup menu of your browser and find the options for the cache (every browser gives you the option to delete the cache). After you deleted the browser cache, load localhost again and press key F5 (what does a refresh).

After then the browser *should* display the new contents instead of the cache.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests