gcc errors in XAMPP install

Problems with the Linux version of XAMPP, questions, comments, and anything related.

gcc errors in XAMPP install

Postby SAJM » 12. February 2014 16:43

What is this all about?

I have a laptop running Slackware 12-1 and tried to install XAMPP. Here are the errors:

Warning: Problem running post install step. Installatiom may not complete correctly
Error running /opt/lammp/ctlscript.sh restart apache : httpd: Syntax error on line 522 of
/opt/lampp/etc/httpd.conf: Syntax error on line 10 of /opt/lampp/etc/extra/httpd-xsmpp.conf:
Cannot load modules/libphp5.so into server: /usr/lib/libgcc_s.so.1: version 'GCC_4.2.0'
not found (required by /opt/lampp/lib/libstdc++.so.6)
httpd: Syntax error on line 522 of /opt/lampp/etc/httpd.conf: Syntax error on line 10
of /opt/lampp/etc/extra/httpd-xsmpp.conf: Cannot load modules/libphp5.so into server:
/usr/lib/libgcc_s.so.1: version 'GCC_4.2.0' not found (required by /opt/lampp/lib/libstdc++.so.6)
Press [Enter] to continue :
#

--------------------------------------------------
Setup has finished installing XAMPP on your computer.

# /opt/lampp/lampp start
Starting XAMPP for linux 1.8.3-2...
XAMPP: Starting Apache...fail
httpd: httpd: Syntax error on line 522 of /opt/lampp/etc/httpd.conf: Syntax error on line 10
of /opt/lampp/etc/extra/httpd-xsmpp.conf: Cannot load modules/libphp5.so into server:
/usr/lib/libgcc_s.so.1: version 'GCC_4.2.0' not found (required by /opt/lampp/lib/libstdc++.so.6)
XAMMP: Starting MySQL...ok
XAMPP: Starting ProFTPD...Fail
XAMPP: Another FTP Daemon is already running.
root@steve:\# /opt/lampp/bin/my_print_defaults: /usr/lib/libgcc_s.co.1: version 'GCC_4.2.0' not found
(required by /opt/lampp/lib/libstdc++.so.6)

Im not sure where to start?

Thanks
SAJM
 
Posts: 4
Joined: 12. February 2014 15:55
Operating System: Slackware 12.1

Re: gcc errors in XAMPP install

Postby Nobbie » 12. February 2014 17:00

It seems you have no C-Compiler installed (gcc is a C-Compiler). Install the gcc package from Slackware and then try again.
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04

Re: gcc errors in XAMPP install

Postby SAJM » 12. February 2014 17:33

gcc was installed and running, I just compiled a Hello World program to make sure :-)
SAJM
 
Posts: 4
Joined: 12. February 2014 15:55
Operating System: Slackware 12.1

Re: gcc errors in XAMPP install

Postby SAJM » 12. February 2014 17:56

Here is what I have re: gcc

root@steve:/home/steve# gcc -v
Reading specs from /usr/lib/gcc/i486-slackware-linux/4.1.2/specs
Target: i486-slackware-linux
Configured with: ../gcc-4.1.2/configure --prefix=/usr --enable-shared --enable-l
anguages=ada,c,c++,fortran,java,objc --enable-threads=posix --enable-__cxa_atexi
t --disable-checking --with-gnu-ld --verbose --with-arch=i486 --target=i486-slac
kware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.1.2
root@steve:/home/steve#
SAJM
 
Posts: 4
Joined: 12. February 2014 15:55
Operating System: Slackware 12.1

Re: gcc errors in XAMPP install

Postby SAJM » 12. February 2014 19:11

AH!!! I've just seen it. XAMPP calls for gcc 4.2. My version is 4.1. I wonder if that's the problem?!!!
SAJM
 
Posts: 4
Joined: 12. February 2014 15:55
Operating System: Slackware 12.1

Re: gcc errors in XAMPP install

Postby Nobbie » 18. February 2014 11:59

SAJM wrote:AH!!! I've just seen it. XAMPP calls for gcc 4.2. My version is 4.1. I wonder if that's the problem?!!!


Of course it is - you have to go for the newer release (if there is no for your system, you cannot run Xampp).
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests