Connecting Valentina Studio to the XAMPP database

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Connecting Valentina Studio to the XAMPP database

Postby bunnybooboo » 16. December 2013 23:04

Hey folks.

I managed to install XAMPP successfully on my netbook and can access it via the browser and navigate to phpMyAdmin. Also got them up and selectable within terminal. I'm trying to get access via a local GUI client though and have had trouble connecting to the database server all day. I'm trying to use VALENTINA STUDIO which came highly recommended on many forums.

I input the TCP/IP settings OR try the myqld.sock method and both are knocking me out with an error HY000: "Can't connect to MySQL server on '127.0.0.1' (107)"

This is a brand new install of XAMPP.

I setup the security settings in the browser for XAMPP and have saved them each in LASTPASS so I know the passwords and users are correct. I've tried the XAMPP user and pword, the PMA user and pword, and ROOT user and pword.

I've also located the mysqld.sock at /opt/lampp/var/mysql/mysqld.sock It's an empty file though is this correct? Following a suggestion on the Ubuntu forums from 2009 I attempted
Code: Select all
mkdir /var/run/mysqld

and then
Code: Select all
sudo ln -s /opt/lampp/var/mysql/mysql.sock /var/run/mysqld/mysqld.sock

Unfortunately it didn't work. :cry:

In MySQL I have TWO databases - one called mysql and another called phpmyadmin. The latter seems mostly empty and mysql seems to have all the user data and host settings. Try to get the info for the 'host' table and the privileges direct me to the 'db' table instead as it has a 'host' column. There are three entries there. Two tests using % but with nothing in the user field, and the 'pma' user for the phpmyadmin database.

From what I can understand I need to get a wildcard '%' into the host for the 'pma' user. I can't get it to alter though. I'm trying via phpMyAdmin. I even tried creating a new user with the same privileges as the current 'pma' user and it won't save it.

The current previlieges for 'pma' user (which is the root user fro phpMyAdmin) are on for:
select
insert
update
delete
execute

Going to see if via terminal I can force privileges onto that user.
Last edited by bunnybooboo on 17. December 2013 11:01, edited 2 times in total.
bunnybooboo
 
Posts: 6
Joined: 16. December 2013 22:55
XAMPP Version: 5.5.19
Operating System: Lubuntu 13.10

Re: Connecting Valentina Studio to the XAMPP database

Postby bunnybooboo » 17. December 2013 00:52

Wow I think I'm finally getting somewhere!! After trying this method
http://www.magentodeveloperleedsuk.co.uk/reset-mysql-root-password-in-lampp-xampp/

where you skip-grant-tables in /opt/lampp/etc/my.cnf under [mysqld]

this allowed me to FINALLY set the wildcard '%' for the 'pma' user in phpMyAdmin. Well I'll be if I still can NOT connect via Valentina. I even restarted XAMPP so it flushed.

Any advice anyone? I'll clearly need to create a new password [EDIT: I've done this now] for the root user whilst I'm on a roll and maybe there is another setting somewhere stopping 'remote' access even though it's on the same lame old reconditioned netbook haha.
bunnybooboo
 
Posts: 6
Joined: 16. December 2013 22:55
XAMPP Version: 5.5.19
Operating System: Lubuntu 13.10

Re: Connecting Valentina Studio to the XAMPP database

Postby bunnybooboo » 17. December 2013 08:54

And since this morning when trying from terminal
Code: Select all
$ mysql -u root
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

[EDIT: I've confirmed the sock file (empty??) is still in it's original location]

also when logging into phpMyAdmin now and attempting the code from the link in my 2nd post
Code: Select all
UPDATE mysql.USER SET Password='new_password' WHERE USER='root'

I get and error
#1142 - UPDATE command denied to user 'pma'@'localhost' for table 'USER'

if I'm logged in as 'pma' and the follow when I'm 'root'
#1142 - UPDATE command denied to user ''@'localhost' for table 'USER'
Last edited by bunnybooboo on 17. December 2013 10:03, edited 1 time in total.
bunnybooboo
 
Posts: 6
Joined: 16. December 2013 22:55
XAMPP Version: 5.5.19
Operating System: Lubuntu 13.10

Re: Connecting Valentina Studio to the XAMPP database

Postby bunnybooboo » 17. December 2013 09:22

What I also now can't fathom is why as root I have access to only two areas in the left of phpMyAdmin: information_schema and test. I can't even select the tables without an error popping up. Under 'databases' tab under create databases it now says 'no privileges'.

Logging in as 'root' is currently done without a password. Right I'm going through all the XAMPP security settings again as I think I'd duplicated the XAMPP browser interface password with root user. Whilst correcting this I notice the settings say
XAMPP: MySQL is not accessable via network. Good.

No that's BAAAADD lol. Isn't it? How do I change that?
bunnybooboo
 
Posts: 6
Joined: 16. December 2013 22:55
XAMPP Version: 5.5.19
Operating System: Lubuntu 13.10

Re: Connecting Valentina Studio to the XAMPP database

Postby bunnybooboo » 17. December 2013 10:09

Checking through everything I'd done I found the mysqld directory I'd created back in my op and this had vanished. Woah. Anyway done the procedure again and restored terminal access to mySQL. So if anyone has any suggestions of assistance I will be able to run them through terminal.
bunnybooboo
 
Posts: 6
Joined: 16. December 2013 22:55
XAMPP Version: 5.5.19
Operating System: Lubuntu 13.10

Re: Connecting Valentina Studio to the XAMPP database

Postby bunnybooboo » 17. December 2013 17:49

I'm still pressing on with this..

When I get into the skip-grant-tables version of pmpMyADmin I tried to run
Code: Select all
UPDATE mysql.USER SET Password='new_password' WHERE USER='root'

and get
#1146 - Table 'mysql.USER' doesn't exist


EDIT: it turns out this is because it had it in caps. Running the SQL query now runs with out an error BUT seems to not effect the root user despite removing the password manually in phpmyadmin. I also have just tried via terminal and it SEEMS to work but responds with no error but a new line with '->' symbol.

so typical of trying to find the answer for open source software I have gone down so many rabbit trails and not sure if I'm any closer.

The 'user' table from mysql actually has FIVE fields in there.
1) host: % - user 'root' - password blank
2) host: linux - user 'root' - password blank
3) host: localhost - user blank - password blank
4) host: linux - user blank - password blank
5) host: localhost - user 'pma' - password - encrypted password


When I attempt to go via
/opt/lampp/xampp security

I get asked to create a password for pma

I'm quite new to mysql and actually trying to follow a tutorial on XAMPP so am keeping it specifically identical to the tutorial in the hope I might be able to reduce complexities. Mahaha.

To add another complexity when I use root without the password and skip-grant-tables I actually only have TWO databases.
pma user when logged in with skip-grant-tables gets THREE databases
root user WITH skip-grant-tables gets EIGHT
pma user WITH skip-grant-tables gets EIGHT

I know I seem to be rather talking to myself here after so many posts to myself but it seems to me and my quite newbie brain that 'pma' actually IS recognised as the root user. I can't work that out though as 'pma' user clearly has far less privileges granted to it when looking of the 'user' table in mysql.

Within this table I have just deleted all the passwords and when trying to log back in via phpmyadmin neither 'root' nor 'pma' users can get in. Sweet. But when I try to reset the password via /opt/lampp/xampp security it still says
XAMPP: MySQL has a root passwort set. Fine! :)


How many variations are there??
bunnybooboo
 
Posts: 6
Joined: 16. December 2013 22:55
XAMPP Version: 5.5.19
Operating System: Lubuntu 13.10


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests