Cant create database #1044 access denied

Problems with the Linux version of XAMPP, questions, comments, and anything related.

phpMyAdmin not showing my databases

Postby originalhandy » 24. September 2013 05:03

I have been using XAMPP for about a year and upgraded to 1.8.2 about 2 months ago.
When I logged onto localhost/phpmyadmin and got the XAMPP message about new changes in the http-conf file I think it was. (New XAMPP security concept)
I did /opt/lampp/lampp security

Now I can access localhost/phpmyadmin but it dos not show any of my databases from my website. I see information schema, mysql, phpmyadmin and test. None of these are my websites.
When I go to /var/mysql my databse for my website is in there. Any ideas ?
originalhandy
 
Posts: 5
Joined: 24. September 2013 04:47
Operating System: openSUSE 11.4 (i586)

Re: phpMyAdmin not showing my databases

Postby Altrea » 24. September 2013 05:29

you are logged in with an anonymous user who don't has any permissions.

change your phpMyAdmin setting auth_type from "config" to "cookie" and log in manually with your new credentials.
http://docs.phpmyadmin.net/en/latest/co ... _auth_type
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: phpMyAdmin not showing my databases

Postby originalhandy » 24. September 2013 18:07

Thanks you were spot on!
originalhandy
 
Posts: 5
Joined: 24. September 2013 04:47
Operating System: openSUSE 11.4 (i586)

Cant create database #1044 access denied

Postby originalhandy » 27. September 2013 19:35

I did a reinstall to the latest XAMPP and when I am on loclahost/phpmyadmin and try to create a database I get
Code: Select all
#1044 Access denied for user "@'localhost' to database 'website'


SQL is started, fresh install. I have done /opt/lampp/lampp security also.

LAMPP is running fine it says
Code: Select all
Version: XAMPP for Linux 1.8.3-1
Apache is running.
MySQL is running.
ProFTPD is running.
ws-19476:/opt/lampp/phpmyadmin #



Any ideas ?

I have auth set to cookie, do I need to edit anythng else there
Code: Select all
 * First server
 */
$i++;
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
/* Server parameters */
//$cfg['Servers'][$i]['host'] = 'localhost';
//$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysql if your server does not have mysqli */
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;



[Moderated by Altrea: Merged Threads]
originalhandy
 
Posts: 5
Joined: 24. September 2013 04:47
Operating System: openSUSE 11.4 (i586)

Re: Cant create database #1044 access denied

Postby Altrea » 27. September 2013 21:16

login with root@localhost not with anonymous@localhost.
I have already told you that so please stop creating new threads for the same issue
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests