APACHE IS STARTING BUT NOT AS A DAEMON...

Problems with the Linux version of XAMPP, questions, comments, and anything related.

APACHE IS STARTING BUT NOT AS A DAEMON...

Postby caranicola » 16. July 2004 01:16

I have a major problem and I hope Kris or some other members can help me!... I tahnk you in advance for your reply!
I instaled XAMPP for Linux (v1.4.6) on a RH7 OS, and after that, I made the command "/opt/lampp/lampp start". It tells me that all the processes are started
[root@cnet xampp]# /opt/lampp/lampp start -k
Starting XAMPP for Linux 1.4.6...
XAMPP: Starting Apache with SSL...
XAMPP: XAMPP-MySQL is already running.
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

In fact only proFTPD server and mysql server are started and running on the machine, while APACHE is DEAD!...
I make again the special command for starting only apache, "/opt/lampp/lampp start" but the same thing happens...the console tells that apache is starting but in fact it is shutdown imediatly after gets started...

I know from a friend that I have to make apache starts like a daemon...
but how to do that on under XAMPP?...

Thank you all for repling, in advance!
caranicola
 
Posts: 2
Joined: 16. July 2004 00:26
Location: Wageningen

Postby gRF » 06. October 2004 09:00

I have exactly the same problem - mysql & ftp start nice. Apache is starting, starting... and it never starts.

I have Debian 3.02 Stable, kernel 2.6.6, and lampp 1.4.9a.
Very similar machine ( Debian Stable + kernel 2.4 ) works just fine.

Did you manage to find a solution ?

In httpd.conf, I tried commenting out line :
Code: Select all
#LoadModule auth_digest_module modules/mod_auth_digest.so

and then apache started, but when i wanted to stopapache, it got stuck again...

Anybody, any ideas ? :)
Bolé _ Bozidar Mladenovic
Exit Pte Ltd, Web Design & Development, Singapore
bolle (at) exit.sg
gRF
 
Posts: 1
Joined: 12. September 2004 22:13
Location: Singapore

Postby Kristian Marcroft » 06. October 2004 09:11

Hi,

Try this:

http://www.apachefriends.org/en/faq-xam ... html#score

It would be more interesseting if you had a look at the error_log and paste it here.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests