perl problem

Problems with the Linux version of XAMPP, questions, comments, and anything related.

perl problem

Postby mi_techs » 23. June 2004 23:03

I need help badly....

I install XAMPP for linux on RH9, worked fine. Then I changed the directory root to other place, also worked fine. Problem is, when I tried to use perl, laso gives me 500 Internal Server error.
I tried to play around with and without suexec, get even more confuse.
I tried to use user www (instead of nobody), nothing change.

Here is the error_log:

[Wed Jun 23 14:51:05 2004] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: text.cgi, referer: http://xxx.xxx.xxx.xxx~scaaweb/
[Wed Jun 23 14:51:05 2004] [error] [client xxx.xxx.xxx.xxx] failed to open log file, referer: http://xxx.xxx.xxx.xxx/~scaaweb/
[Wed Jun 23 14:51:05 2004] [error] [client xxx.xxx.xxx.xxx] fopen: Permission denied, referer: http://xxx.xxx.xxx.xxx/~scaaweb/
[Wed Jun 23 14:51:06 2004] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: text.cgi, referer: http://xxx.xxx.xxx.xxx/~scaaweb/
[Wed Jun 23 14:51:06 2004] [error] [client xxx.xxx.xxx.xxx] failed to open log file, referer: http://xxx.xxx.xxx.xxx/~scaaweb/
[Wed Jun 23 14:51:06 2004] [error] [client xxx.xxx.xxx.xxx] fopen: Permission denied, referer: http://xxx.xxx.xxx.xxx/~scaaweb/
[Wed Jun 23 14:51:08 2004] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: text.cgi, referer: http://xxx.xxx.xxx.xxx/~scaaweb/
[Wed Jun 23 14:51:08 2004] [error] [client xxx.xxx.xxx.xxx] failed to open log file, referer: http://xxx.xxx.xxx.xxx/~scaaweb/
[Wed Jun 23 14:51:08 2004] [error] [client xxx.xxx.xxx.xxx] fopen: Permission denied, referer: http://xxx.xxx.xxx.xxx/~scaaweb/

xxx.xxx.xxx.xxx is the ip address

and here is the suexec_log:

[2004-06-23 14:37:26]: uid: (15011/scaaweb) gid: (1511/1511) cmd: alum.cgi
[2004-06-23 14:37:29]: uid: (15011/scaaweb) gid: (1511/1511) cmd: alum.cgi
[2004-06-23 14:37:31]: uid: (15011/scaaweb) gid: (1511/1511) cmd: text.cgi
[2004-06-23 14:37:34]: uid: (15011/scaaweb) gid: (1511/1511) cmd: alum.cgi
[2004-06-23 14:48:53]: uid: (15011/scaaweb) gid: (1511/1511) cmd: text.cgi
[2004-06-23 14:48:54]: uid: (15011/scaaweb) gid: (1511/1511) cmd: text.cgi
[2004-06-23 14:48:57]: uid: (15011/scaaweb) gid: (1511/1511) cmd: text.cgi
[2004-06-23 14:51:05]: uid: (15011/scaaweb) gid: (1511/1511) cmd: text.cgi
[2004-06-23 14:51:06]: uid: (15011/scaaweb) gid: (1511/1511) cmd: text.cgi
[2004-06-23 14:51:08]: uid: (15011/scaaweb) gid: (1511/1511) cmd: text.cgi

here is the access_log:
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:42:46 -0700] "GET /~scaaweb/ HTTP/1.1" 200 153
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:42:48 -0700] "GET /~scaaweb/cgi-bin/alum.cgi HTTP/1.1" 500 546
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:42:52 -0700] "GET /~scaaweb/cgi-bin/text.cgi HTTP/1.1" 500 546
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:48:53 -0700] "GET /~scaaweb/cgi-bin/text.cgi HTTP/1.1" 500 546
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:48:54 -0700] "GET /~scaaweb/cgi-bin/text.cgi HTTP/1.1" 500 546
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:48:57 -0700] "GET /~scaaweb/ HTTP/1.1" 200 153
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:48:57 -0700] "GET /~scaaweb/cgi-bin/text.cgi HTTP/1.1" 500 546
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:51:05 -0700] "GET /~scaaweb/cgi-bin/text.cgi HTTP/1.1" 500 546
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:51:06 -0700] "GET /~scaaweb/cgi-bin/text.cgi HTTP/1.1" 500 546
xxx.xxx.xxx.xxx - - [23/Jun/2004:14:51:08 -0700] "GET /~scaaweb/cgi-bin/text.cgi HTTP/1.1" 500 546


Please please please, any help...........
mi_techs
 
Posts: 4
Joined: 12. June 2004 08:49

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests