Permissions issues

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Permissions issues

Postby mrgreen » 18. June 2004 07:26

So far I've been really impressed with XAMPP, great job on building such a useful app!

I just installed it, but I'm a bit of a noob, though, and I am having trouble putting my website files into /opt/lampp/htdocs. I installed XAMPP as root, as per the instructions on this site, but I am not root when I use my linux box, nor do I want to be just to do web development. I suppose if I have to I can, but I'd rather just set it up for regular user accounts to be able to read/write to /opt/lampp.

Can anyone provide any insight into how I might do this? I've played around with the user/groups utility in linux, but it didn't do much. I tried adding my user account to the 'root' group with the hopes of gaining read/write access to /opt/lampp, but to no avail.

Any help is greatly appreciated.

Posts: 2
Joined: 18. June 2004 07:16

Postby UmneyDurak » 21. June 2004 01:18

in console change to thelampp derictory, change to root by typing su.
Then type chmod 777 htdocs. This allows for user (root), group (root), and everyone else to read write and execute this folder.
Check out this site for more info:
This is how we fix things in Russia!!!! *hits computer with his foot. :)
Posts: 6
Joined: 11. June 2004 05:51

Postby mrgreen » 21. June 2004 07:58

Thanks Umney
Posts: 2
Joined: 18. June 2004 07:16


Postby valentijn » 13. July 2004 17:40

Even with the very secirity unwise 777 chmods..... I got thes errors
when logged locally on mij webserver :

Warning: file_get_contents(lang.tmp): failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/index.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/index.php:2) in /opt/lampp/htdocs/xampp/index.php on line 4

How can I fix this !
seesm that the core apache works because phpmyadmin asks for recondifuration etc... When installed on my Windows machine erverything was ok in one roll... but on linux not......sadly
Posts: 2
Joined: 13. July 2004 17:12

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests