php SQLite3 no such module: fts3- ubuntu[solved]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

php SQLite3 no such module: fts3- ubuntu[solved]

Postby huixia0010 » 20. June 2013 12:02

I tried google and find two articles about it .
And with the sqlite introduction link http://www.sqlite.org/fts3.html#section_2
I use Development package and download the php-5.4.7.tar.gz(http://us1.php.net/distributions/php-5.4.7.tar.gz) try to compilatie the sqlite3. But when I cd into php-5.4.7\ext\sqlite3 and use /opt/lampp/bin/phpizethe, it shows "can not find config.m4. Make sure that you run '/opt/lampp/bin/phpize' in the top level source directory of the module".

Is there some knows what I can do to solve it? Thank you for your help~~^_^

PS:The two articles are here and I think they are useless for my problem:
http://stackoverflow.com/questions/6754212/linux-how-to-install-fts3-for-sqlite3-in-php
http://stackoverflow.com/questions/948899/how-to-enable-sqlite3-for-php
Last edited by huixia0010 on 25. June 2013 03:55, edited 1 time in total.
huixia0010
 
Posts: 2
Joined: 20. June 2013 11:42
XAMPP Version: 5.6.3
Operating System: ubuntu 12.04 X86

Re: Php SQLite3 no such module: fts3- ubuntu server 12.04 X

Postby huixia0010 » 23. June 2013 11:47

1.download http://www.apachefriends.org/download.php?xampp-linux-devel-1.8.1.tar.gz
2.tar xf ?xampp-linux-devel-1.8.1.tar.gz -C /opt
3.download http://ar2.php.net/distributions/php-5.4.16.tar.gz
4.tar xf php-5.4.16.tar.gz -C /opt
5.cd php-5.4.15。
6.
./configure --prefix=/opt/lampp/php-5.4.15 --enable-fpm --with-apxs2=/opt/lampp/bin/apxs --with-mysql=mysqlnd --with-zlib=yes --with-zlib-dir=/opt/lampp --with-mysql-sock=/opt/lampp/var/mysql/mysql.sock --enable-mbstring=all --with-curl=/opt/lampp --enable-mbregex --with-mysqli=mysqlnd --with-iconv --with-pdo-mysql=mysqlnd --with-pdo-sqlite --with-libxml-dir=/opt/lampp
make
sudo make install
/opt/lampp/lampp restart

This solution from GF→http://gfzj.us/
huixia0010
 
Posts: 2
Joined: 20. June 2013 11:42
XAMPP Version: 5.6.3
Operating System: ubuntu 12.04 X86


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests