I can't start Apache and ProFTPD

Problems with the Linux version of XAMPP, questions, comments, and anything related.

I can't start Apache and ProFTPD

Postby Greduan » 21. April 2013 23:27

I'm on Arch Linux the latest version with E17 (Enlightenment v0.17).

When I try running `sudo xampp start` or `sudo lampp start` I get the following:
Code: Select all
Starting XAMPP for Linux 1.8.1...
XAMPP: Starting Apache with SSL (and PHP5)...
/opt/lampp/bin/apachectl: line 79:  3706 Segmentation fault      (core dumped) $HTTPD "$@"
XAMPP: Error 139! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP: dhcppc2 proftpd[4121]: warning: unable to determine IP address of 'dhcppc2'
dhcppc2 proftpd[4121]: error: no valid servers configured
dhcppc2 proftpd[4121]: Fatal: error processing configuration file '/opt/lampp/etc/proftpd.conf'
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for Linux started

The contents of everything related to line 79 of the /opt/lampp/bin/apachectl file is the following:
Code: Select all
case $ACMD in
    $HTTPD -k $ARGV
    echo The startssl option is no longer supported.
    echo Please edit httpd.conf to include the SSL configuration settings
    echo and then use "apachectl start".
    $HTTPD -t
    $LYNX $STATUSURL | awk ' /process$/ { print; exit } { print } '
    $HTTPD "$@"

The contents of the /opt/lampp/etc/proftpd.conf file:
Code: Select all
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName         "ProFTPD"
ServerType         standalone
DefaultServer         on

# Port 21 is the standard FTP port.
Port            21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask            022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances         30

# Set the user and group that the server normally runs at.
User            nobody
#Group            nogroup

# Normally, we want files to be overwriteable.
<Directory /opt/lampp/htdocs/*>
  AllowOverwrite      on

# only for the web servers content
DefaultRoot /opt/lampp/htdocs

# nobody gets the password "lampp"
UserPassword nobody XXXXXXXXXXXXX

# nobody is no normal user so we have to allow users with no real shell
RequireValidShell off

# nobody may be in /etc/ftpusers so we also have to ignore this file
UseFtpUsers off

I X'd out any data that I thought may be private. :)

Thanks for any help you can provide. ;)
Posts: 1
Joined: 21. April 2013 22:55
XAMPP Version: 5.6.3
Operating System: Arch Linux v3.8.4 with E17

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests