Cannot start MySQL with XAMPP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Cannot start MySQL with XAMPP

Postby anber » 09. April 2013 12:54

am trying to start mysql with XAMPP without success. The Apache works fine, but when the mysql try to start show Couldn't start MySQL!

here is the log
130408 11:07:05 mysqld_safe Starting mysqld daemon with databases from /u01/lampp/lampp/var/mysql
130408 11:07:05 [Note] Plugin 'FEDERATED' is disabled.
130408 11:07:05 InnoDB: The InnoDB memory heap is disabled
130408 11:07:05 InnoDB: Mutexes and rw_locks use InnoDB's own implementation
130408 11:07:05 InnoDB: Compressed tables use zlib 1.2.3
130408 11:07:05 InnoDB: Initializing buffer pool, size = 128.0M
130408 11:07:05 InnoDB: Completed initialization of buffer pool
130408 11:07:05 InnoDB: highest supported file format is Barracuda.
130408 11:07:05 InnoDB: Waiting for the background threads to start
130408 11:07:06 InnoDB: 1.1.8 started; log sequence number 1595675
130408 11:07:06 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
130408 11:07:06 [Note] - '0.0.0.0' resolves to '0.0.0.0';
130408 11:07:06 [Note] Server socket created on IP: '0.0.0.0'.
130408 11:07:06 [ERROR] Can't start server : Bind on unix socket: No such file or directory
130408 11:07:06 [ERROR] Do you already have another mysqld server running on socket: /opt/lampp/var/mysql/mysql.sock ?
130408 11:07:06 [ERROR] Aborting

130408 11:07:06 InnoDB: Starting shutdown...
130408 11:07:06 InnoDB: Shutdown completed; log sequence number 1595675
130408 11:07:06 [Note] /u01/lampp/lampp/sbin/mysqld: Shutdown complete

130408 11:07:06 mysqld_safe mysqld from pid file /u01/lampp/lampp/var/mysql/JOOMLA.pid ended

in my.cnf says:
socket = /var/lib/mysql/mysql.sock

The file mysql.sock is not created. Any idea?

Thanks in advance.

Andrés.
anber
 
Posts: 2
Joined: 09. April 2013 12:51
XAMPP Version: 5.6.3
Operating System: Linux Red Hat 5

Re: Cannot start MySQL with XAMPP

Postby anber » 09. April 2013 14:25

solved, i created the folder specified in the error log and works fine!
anber
 
Posts: 2
Joined: 09. April 2013 12:51
XAMPP Version: 5.6.3
Operating System: Linux Red Hat 5


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests