[SOLVED] Can't access http://localhost

Problems with the Linux version of XAMPP, questions, comments, and anything related.

[SOLVED] Can't access http://localhost

Postby Gretgor » 14. March 2013 15:18

I have installed xampp 1.8.1 because I need to put up a website for the place I work at, but even though apparently everything runs fine when starting up xampp, Firefox can't locate http://localhost nor http://127.0.0.1

When I try pinging localhost or 127.0.0.1, it works normally, but I can't access it with Firefox or any other browser. Firefox outputs "couldn't establish connection with localhost server" (roughly translated from the portuguese version of Firefox).

I haven't changed anything as of yet in what concerns the website's root directory or any internal configurations, I simply installed xampp 1.8.1, ran the ./lampp start command, and tried to access the test page before I actually started working on things.

I am using Ubuntu 12.04.2 LTS, with a 64-bit installation (which means I had to get that freaky ia32-libs package in order to run, could this be the problem?)

^xampp/logs/error_log contains:

Code: Select all
[Thu Mar 14 10:44:23.129432 2013] [ssl:warn] [pid 16782] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Mar 14 10:44:23.129481 2013] [ssl:warn] [pid 16782] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Thu Mar 14 10:44:23.129499 2013] [suexec:notice] [pid 16782] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Thu Mar 14 10:44:23.219879 2013] [auth_digest:notice] [pid 16783] AH01757: generating secret for digest authentication ...
[Thu Mar 14 10:44:24.054218 2013] [ssl:warn] [pid 16783] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Mar 14 10:44:24.054241 2013] [ssl:warn] [pid 16783] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Thu Mar 14 10:44:24.054264 2013] [lbmethod_heartbeat:notice] [pid 16783] AH02282: No slotmem from mod_heartmonitor
[Thu Mar 14 10:44:24.058551 2013] [mpm_prefork:notice] [pid 16783] AH00163: Apache/2.4.3 (Unix) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Thu Mar 14 10:44:24.058578 2013] [core:notice] [pid 16783] AH00094: Command line: '/opt/lampp/bin/httpd -D SSL -D PHP5 -E /opt/lampp/logs/error_log'


All other error logs are empty.
Last edited by Gretgor on 25. March 2013 14:23, edited 1 time in total.
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS

Re: xampp starts normally, but I can't access http://localho

Postby Gretgor » 14. March 2013 18:18

Update:

I tried erasing ^xampp/logs/httpd.pid due to someone saying that solved a similar problem of theirs, and now Apache won't start at all:

The command line ./lampp start outputs:
Code: Select all
Starting XAMPP for Linux 1.8.1...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.


^xampp/logs/error_log contais:

Code: Select all
[Thu Mar 14 14:11:00.692285 2013] [mpm_prefork:notice] [pid 25798] AH00169: caught SIGTERM, shutting down
[Thu Mar 14 14:11:10.077740 2013] [ssl:warn] [pid 7369] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Mar 14 14:11:10.077790 2013] [ssl:warn] [pid 7369] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Thu Mar 14 14:11:10.077808 2013] [suexec:notice] [pid 7369] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Thu Mar 14 14:11:10.168509 2013] [auth_digest:notice] [pid 7370] AH01757: generating secret for digest authentication ...
[Thu Mar 14 14:11:11.016799 2013] [ssl:warn] [pid 7370] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Mar 14 14:11:11.016823 2013] [ssl:warn] [pid 7370] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Thu Mar 14 14:11:11.016846 2013] [lbmethod_heartbeat:notice] [pid 7370] AH02282: No slotmem from mod_heartmonitor
[Thu Mar 14 14:11:11.021122 2013] [mpm_prefork:notice] [pid 7370] AH00163: Apache/2.4.3 (Unix) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Thu Mar 14 14:11:11.021141 2013] [core:notice] [pid 7370] AH00094: Command line: '/opt/lampp/bin/httpd -D SSL -D PHP5 -E /opt/lampp/logs/error_log'
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs


Still no solution, and I'm wondering if I'll have to start it all over now.
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS

Re: xampp starts normally, but I can't access http://localho

Postby Gretgor » 15. March 2013 14:07

Update:

After making changes to both httpd.conf and httpd-ssl.conf to try different ports, I got apache to start again, but I still can't access localhost.

error_log:
Code: Select all
[Fri Mar 15 10:05:16.017387 2013] [ssl:warn] [pid 10850] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Mar 15 10:05:16.017438 2013] [ssl:warn] [pid 10850] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Fri Mar 15 10:05:16.017455 2013] [suexec:notice] [pid 10850] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Fri Mar 15 10:05:16.108824 2013] [auth_digest:notice] [pid 10851] AH01757: generating secret for digest authentication ...
[Fri Mar 15 10:05:17.067276 2013] [ssl:warn] [pid 10851] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Mar 15 10:05:17.067303 2013] [ssl:warn] [pid 10851] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Fri Mar 15 10:05:17.067326 2013] [lbmethod_heartbeat:notice] [pid 10851] AH02282: No slotmem from mod_heartmonitor
[Fri Mar 15 10:05:17.071595 2013] [mpm_prefork:notice] [pid 10851] AH00163: Apache/2.4.3 (Unix) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Fri Mar 15 10:05:17.071623 2013] [core:notice] [pid 10851] AH00094: Command line: '/opt/lampp/bin/httpd -D SSL -D PHP5 -E /opt/lampp/logs/error_log'


Basically the same thing as the last one.

EDIT: After changing ServerName to "<my-actual-servername>:<my-actual-port>" in httpd-ssl.conf, I managed to get rid of the SSL error, but not being able to access the website persists.

error_log:

Code: Select all
[Fri Mar 15 10:12:46.698670 2013] [mpm_prefork:notice] [pid 10851] AH00169: caught SIGTERM, shutting down
[Fri Mar 15 10:12:53.036205 2013] [ssl:warn] [pid 11020] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Mar 15 10:12:53.036267 2013] [suexec:notice] [pid 11020] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Fri Mar 15 10:12:53.126746 2013] [auth_digest:notice] [pid 11021] AH01757: generating secret for digest authentication ...
[Fri Mar 15 10:12:54.093162 2013] [ssl:warn] [pid 11021] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Mar 15 10:12:54.093207 2013] [lbmethod_heartbeat:notice] [pid 11021] AH02282: No slotmem from mod_heartmonitor
[Fri Mar 15 10:12:54.097468 2013] [mpm_prefork:notice] [pid 11021] AH00163: Apache/2.4.3 (Unix) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Fri Mar 15 10:12:54.097497 2013] [core:notice] [pid 11021] AH00094: Command line: '/opt/lampp/bin/httpd -D SSL -D PHP5 -E /opt/lampp/logs/error_log'


I guess I still need help. http://localhost still doesn't function, nor does http://localhost:8082, nor http://127.0.0.1, nor http://127.0.0.1:8082...

My httpd.conf (output generated with grep -v "\#" httpd.conf | grep -v "^$", to remove the commented parts and the thousands of line breaks)

Code: Select all
ServerRoot "/opt/lampp"
Listen 8082
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbd_module modules/mod_authn_dbd.so
LoadModule authn_socache_module modules/mod_authn_socache.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authz_dbd_module modules/mod_authz_dbd.so
LoadModule authz_core_module modules/mod_authz_core.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule access_compat_module modules/mod_access_compat.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_form_module modules/mod_auth_form.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule allowmethods_module modules/mod_allowmethods.so
LoadModule file_cache_module modules/mod_file_cache.so
LoadModule cache_module modules/mod_cache.so
LoadModule cache_disk_module modules/mod_cache_disk.so
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so
LoadModule socache_dbm_module modules/mod_socache_dbm.so
LoadModule socache_memcache_module modules/mod_socache_memcache.so
LoadModule dbd_module modules/mod_dbd.so
LoadModule bucketeer_module modules/mod_bucketeer.so
LoadModule dumpio_module modules/mod_dumpio.so
LoadModule echo_module modules/mod_echo.so
LoadModule case_filter_module modules/mod_case_filter.so
LoadModule case_filter_in_module modules/mod_case_filter_in.so
LoadModule buffer_module modules/mod_buffer.so
LoadModule ratelimit_module modules/mod_ratelimit.so
LoadModule reqtimeout_module modules/mod_reqtimeout.so
LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule request_module modules/mod_request.so
LoadModule include_module modules/mod_include.so
LoadModule filter_module modules/mod_filter.so
LoadModule substitute_module modules/mod_substitute.so
LoadModule sed_module modules/mod_sed.so
LoadModule charset_lite_module modules/mod_charset_lite.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule mime_module modules/mod_mime.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule log_debug_module modules/mod_log_debug.soListen 433
SSLCipherSuite HIGH:MEDIUM:!aNULL:!MD5
SSLPassPhraseDialog  builtin
SSLSessionCache        "shmcb:/opt/lampp/logs/ssl_scache(512000)"
SSLSessionCacheTimeout  300
<VirtualHost _default_:443>
DocumentRoot "/opt/lampp/htdocs"
ServerName localhost:433
ServerAdmin you@example.com
ErrorLog "/opt/lampp/logs/error_log"
TransferLog "/opt/lampp/logs/access_log"
SSLEngine on
SSLCertificateFile "/opt/lampp/etc/ssl.crt/server.crt"
SSLCertificateKeyFile "/opt/lampp/etc/ssl.key/server.key"
<FilesMatch "\.(cgi|shtml|phtml|php)$">
    SSLOptions +StdEnvVars
</FilesMatch>
<Directory "/opt/lampp/cgi-bin">
    SSLOptions +StdEnvVars
</Directory>
BrowserMatch "MSIE [2-5]" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0
CustomLog "/opt/lampp/logs/ssl_request_log" \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>
LoadModule logio_module modules/mod_logio.so
LoadModule env_module modules/mod_env.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule unique_id_module modules/mod_unique_id.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule version_module modules/mod_version.so
LoadModule remoteip_module modules/mod_remoteip.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so
LoadModule proxy_scgi_module modules/mod_proxy_scgi.so
LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule proxy_express_module modules/mod_proxy_express.so
LoadModule session_module modules/mod_session.so
LoadModule session_cookie_module modules/mod_session_cookie.so
LoadModule session_dbd_module modules/mod_session_dbd.so
LoadModule slotmem_shm_module modules/mod_slotmem_shm.so
LoadModule ssl_module modules/mod_ssl.so
LoadModule lbmethod_byrequests_module modules/mod_lbmethod_byrequests.so
LoadModule lbmethod_bytraffic_module modules/mod_lbmethod_bytraffic.so
LoadModule lbmethod_bybusyness_module modules/mod_lbmethod_bybusyness.so
LoadModule lbmethod_heartbeat_module modules/mod_lbmethod_heartbeat.so
LoadModule unixd_module modules/mod_unixd.so
LoadModule dav_module modules/mod_dav.so
LoadModule status_module modules/mod_status.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule info_module modules/mod_info.so
LoadModule suexec_module modules/mod_suexec.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule cgid_module modules/mod_cgid.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
<IfDefine JUSTTOMAKEAPXSHAPPY>
LoadModule php4_module        modules/libphp4.so
LoadModule php5_module        modules/libphp5.so
</IfDefine>
<IfModule unixd_module>
User nobody
Group nogroup
</IfModule>
ServerAdmin you@example.com
ServerName localhost:8082
<Directory />
    AllowOverride none
    Require all denied
</Directory>
DocumentRoot "/opt/lampp/htdocs"
<Directory "/opt/lampp/htdocs">
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    Require all granted
</Directory>
<IfModule dir_module>
    DirectoryIndex index.html index.html.var index.php index.php3 index.php4
</IfModule>
<Files ".ht*">
   Require all denied
</Files>
ErrorLog "logs/error_log"
LogLevel warn
<IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common
    <IfModule logio_module>
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>
    CustomLog "logs/access_log" common
</IfModule>
<IfModule alias_module>
    ScriptAlias /cgi-bin/ "/opt/lampp/cgi-bin/"
</IfModule>
<IfModule cgid_module>
</IfModule>
<Directory "/opt/lampp/cgi-bin">
    AllowOverride None
    Options None
    Require all granted
</Directory>
<IfModule mime_module>
    TypesConfig etc/mime.types
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz
    AddHandler cgi-script .cgi .pl
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
</IfModule>
EnableMMAP off
EnableSendfile off
Include etc/extra/httpd-multilang-errordoc.conf
Include etc/extra/httpd-autoindex.conf
Include etc/extra/httpd-default.conf
<IfModule proxy_html_module>
Include etc/extra/proxy-html.conf
</IfModule>
<IfModule ssl_module>
<IfDefine SSL>
Include etc/extra/httpd-ssl.conf
</IfDefine>
</IfModule>
<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>
Include etc/extra/httpd-xampp.conf


My httpd-ssl.conf (output generated with grep -v "\#" httpd-ssl.conf | grep -v "^$", to remove the commented parts and the thousands of line breaks)

Code: Select all
Listen 433
SSLCipherSuite HIGH:MEDIUM:!aNULL:!MD5
SSLPassPhraseDialog  builtin
SSLSessionCache        "shmcb:/opt/lampp/logs/ssl_scache(512000)"
SSLSessionCacheTimeout  300
<VirtualHost _default_:443>
DocumentRoot "/opt/lampp/htdocs"
ServerName localhost:433
ServerAdmin you@example.com
ErrorLog "/opt/lampp/logs/error_log"
TransferLog "/opt/lampp/logs/access_log"
SSLEngine on
SSLCertificateFile "/opt/lampp/etc/ssl.crt/server.crt"
SSLCertificateKeyFile "/opt/lampp/etc/ssl.key/server.key"
<FilesMatch "\.(cgi|shtml|phtml|php)$">
    SSLOptions +StdEnvVars
</FilesMatch>
<Directory "/opt/lampp/cgi-bin">
    SSLOptions +StdEnvVars
</Directory>
BrowserMatch "MSIE [2-5]" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0
CustomLog "/opt/lampp/logs/ssl_request_log" \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS

Re: xampp starts normally, but I can't access http://localho

Postby Nobbie » 17. March 2013 15:48

Show us the full output (in a terminal) of:

# sudo ifconfig

P.S.:
I simply installed xampp 1.8.1, ran the ./lampp start command, and tried to access the test page before I actually started working on things.


You have to run the ./lampp start as root! Either do a "su" before executing ./lampp or start it via "sudo ./lampp start".
Nobbie
 
Posts: 7147
Joined: 09. March 2008 13:04

Re: xampp starts normally, but I can't access http://localho

Postby Gretgor » 18. March 2013 13:54

Yeah, I ran lampp as root.

ifconfig

Code: Select all
eth0      Link encap:Ethernet  Endereço de HW 10:bf:48:79:aa:07 
          inet end.: 192.168.5.75  Bcast:192.168.5.255  Masc:255.255.255.0
          endereço inet6: fe80::12bf:48ff:fe79:aa07/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:58187146 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:96815454 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:30168582917 (30.1 GB) TX bytes:109561722099 (109.5 GB)
          IRQ:20 Memória:f7300000-f7320000

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:5491950 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:5491950 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:49686190918 (49.6 GB) TX bytes:49686190918 (49.6 GB)
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS

Re: xampp starts normally, but I can't access http://localho

Postby JonB » 18. March 2013 21:46

A. erasing the httpd-ssl.conf caused the Apache start to fail as by default XAMPP tries to start on both 80 & 443.

this message can be ignored -
[Thu Mar 14 10:44:23.129481 2013] [ssl:warn] [pid 16782] AH01909: RSA certificate configured for http://www.example.com:443 does NOT include an ID which matches the server name

its a default warning (not error) and will not affect XAMPP unless you want to run SSL/HTTPS.
----------------------------------
B. - This looks like something is already running on port 80:
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
---------------------------------------------------
C. - A bit down this looks like a typo -

<VirtualHost _default_:443>
DocumentRoot "/opt/lampp/htdocs"
ServerName localhost:433

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp starts normally, but I can't access http://localho

Postby Gretgor » 19. March 2013 19:42

A - I haven't deleted httpd-ssl.conf

B - I changed the ports, this "could not bind to address" no longer happens. (8082 for httpd, 433 for ssl)

C - I changed the default ssl listening port to 433, and forgot to change it in the whole configuration file.

Firefox and Chrome still refuse to open localhost, localhost:8082, 127.0.0.1 and 127.0.0.1:8082, though.
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS

Re: xampp starts normally, but I can't access http://localho

Postby Nobbie » 20. March 2013 12:14

Maybe you have a firewall running that blocks all requests? Can you "ping" the localhost?

I am running out of ideas.

P.S.: As Port 80 seems already be in use, there maybe already running an Apache server? Or do you have a Skype installation or similar? Can you find out which application already uses Port 80?
Nobbie
 
Posts: 7147
Joined: 09. March 2008 13:04

Re: xampp starts normally, but I can't access http://localho

Postby Gretgor » 20. March 2013 14:49

Yeah, pinging localhost and 127.0.0.1 both work fine :(
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS

Re: xampp starts normally, but I can't access http://localho

Postby JonB » 21. March 2013 15:02

See what is running on port 80 -

http://www.cyberciti.biz/faq/what-proce ... inux-port/

Good Luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp starts normally, but I can't access http://localho

Postby Gretgor » 21. March 2013 18:29

Like I said before, I no longer have the Apache failed to start error. I'm not trying to run Apache at port 80 anymore, I'm trying at port 8082.

There is no longer an error complaining about the port in error_log, so I dunno.

xampp is starting normally now, I just still can't access the page.

Output of "netstat -tulpn | grep :80"
Code: Select all
tcp        0      0 0.0.0.0:80              0.0.0.0:*               OUÇA       7370/httpd     
tcp        0      0 0.0.0.0:8081            0.0.0.0:*               OUÇA       10167/httpd     
tcp        0      0 0.0.0.0:8082            0.0.0.0:*               OUÇA       7245/httpd


8081 is there probably because I tried that before trying 8082. Can I kill these processes without a problem?
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS

Re: xampp starts normally, but I can't access http://localho

Postby JonB » 22. March 2013 13:34

You do know you have to restart Apache every time you make a change to a .conf file, right?
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: xampp starts normally, but I can't access http://localho

Postby Gretgor » 24. March 2013 02:31

Yeah, well, I remember having done so.
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS

Re: xampp starts normally, but I can't access http://localho

Postby Gretgor » 25. March 2013 14:20

Well, localhost works fine on the server, I can enter http://localhost just fine. I was just being stupid and thought that other machines in the same network could do the same.

Still, there are a number of machines that undergo remote boot with PxE through that one, and I'd like to be able to access the website from those as well. I guess I must make another topic for this?

Solution: Well, there is no real solution, I was just being long-winded all along. I was trying to access localhost from another machine which was not the one I started xampp through.
Gretgor
 
Posts: 10
Joined: 14. March 2013 15:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.2 LTS


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests