XAMPP: Error 1! Couldn't start Apache!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP: Error 1! Couldn't start Apache!

Postby sntshkmr60 » 07. March 2013 12:18

Hey!

I am on Fedora 18 using XAMPP 1.8.0.

Here is what I get when I try to start apache:

Code: Select all
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/


MySQL starts without any problem, but the same error comes when I start ProFTPD.

This it my `error_log`:

Code: Select all
[Sun Feb 24 18:18:31.411319 2013] [unique_id:alert] [pid 5379] (EAI 2)Name or service not known: AH01564: unable to find IPv4 address of "santosh"
AH00016: Configuration Failed
[Thu Mar 07 21:53:11.314848 2013] [unique_id:alert] [pid 3451] (EAI 3)Temporary failure in name resolution: AH01564: unable to find IPv4 address of "santosh"
AH00016: Configuration Failed
[Thu Mar 07 16:37:26.529939 2013] [unique_id:alert] [pid 4370] (EAI 2)Name or service not known: AH01564: unable to find IPv4 address of "santosh"
AH00016: Configuration Failed
[Thu Mar 07 16:45:07.746443 2013] [unique_id:alert] [pid 4606] (EAI 2)Name or service not known: AH01564: unable to find IPv4 address of "santosh"
AH00016: Configuration Failed
[Thu Mar 07 16:45:45.241372 2013] [unique_id:alert] [pid 5162] (EAI 2)Name or service not known: AH01564: unable to find IPv4 address of "santosh"
AH00016: Configuration Failed
sntshkmr60
 
Posts: 3
Joined: 07. March 2013 12:02
XAMPP Version: 5.6.3
Operating System: Fedora 18

Re: XAMPP: Error 1! Couldn't start Apache!

Postby Nobbie » 07. March 2013 12:35

Have a look into the error.log of Apache, if you can see any reason (/opt/lampp/apache/logs/error.log or /opt/lampp/logs/error.log).

If there is no error message, try to start apache manually in a terminal and watch out for error messages:

# cd /opt/lampp/bin (or /opt/lampp/apache or similar - I currently have no lampp installation)
# ./httpd
Nobbie
 
Posts: 7004
Joined: 09. March 2008 13:04

Re: XAMPP: Error 1! Couldn't start Apache!

Postby sntshkmr60 » 07. March 2013 12:43

Nobbie wrote:Have a look into the error.log of Apache, if you can see any reason (/opt/lampp/apache/logs/error.log or /opt/lampp/logs/error.log).

If there is no error message, try to start apache manually in a terminal and watch out for error messages:

# cd /opt/lampp/bin (or /opt/lampp/apache or similar - I currently have no lampp installation)
# ./httpd


There is no `/opt/lampp/apache/logs/error.log` or `/opt/lampp/logs/error.log`, but there is a `/opt/lampp/logs/error_log` file which I have already shown in my first post.
sntshkmr60
 
Posts: 3
Joined: 07. March 2013 12:02
XAMPP Version: 5.6.3
Operating System: Fedora 18

Re: XAMPP: Error 1! Couldn't start Apache!

Postby JonB » 07. March 2013 14:30

@ sntshkmr60:

Questi9ons/ hints

A. Ensure you have IPv4 enabled in Fedora.

B. is 'santosh' the folder name of your 'home' or the host/machinename???

C. Did you decide to put the XAMPP DocumentRoot outside the /opt/lampp hierarchy?

Good Luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: XAMPP: Error 1! Couldn't start Apache!

Postby sntshkmr60 » 08. March 2013 05:16

JonB wrote:Ensure you have IPv4 enabled in Fedora.


I have no idea how to do that, can you tell me more about that?

JonB wrote:is 'santosh' the folder name of your 'home' or the host/machinename???


`santosh` is my username as well as hostname, my default bash prompt appears like `santosh@santosh`. Should they be different?!? I don't think so because previous version of lampp worked flawlessly (on different machine).

JonB wrote:Did you decide to put the XAMPP DocumentRoot outside the /opt/lampp hierarchy?


I haven't changed anything after extracting the xampp tarball in /opt
sntshkmr60
 
Posts: 3
Joined: 07. March 2013 12:02
XAMPP Version: 5.6.3
Operating System: Fedora 18

Re: XAMPP: Error 1! Couldn't start Apache!

Postby Nobbie » 08. March 2013 14:59

Can you run a "ifconfig" in a shell (as root) and show us the output.

If have (as well as Jon) the feeling, that there is no TCPIP (or Internet Services or similar) installed.

I have no idea how to do that, can you tell me more about that?


Why do you run Fedora if you have no idea about it? There are plenty of distributions out there with full TCPIP support.

P.S.: Did you try to run httpd manually?
Nobbie
 
Posts: 7004
Joined: 09. March 2008 13:04

Re: XAMPP: Error 1! Couldn't start Apache!

Postby JonB » 08. March 2013 15:48

It may be a general Fedora 17 - 18 issue - Networking is disabled by default apparently

Read this first -

http://codeghar.wordpress.com/2012/03/2 ... checklist/


for the story of a QA trainwreck - read these - :shock:

http://docs.fedoraproject.org/en-US/Fed ... rking.html

http://fedoraproject.org/wiki/Tools/NetworkManager

For working by yourself - try turning on Network Manager

(I use Fedora 14 and 16). They are extremely reliable I have multiple machines/servers running

Good Luck

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests