problem with swiftmailer/pcre in 1.8.1 in ubuntu 12.10 :(

Problems with the Linux version of XAMPP, questions, comments, and anything related.

problem with swiftmailer/pcre in 1.8.1 in ubuntu 12.10 :(

Postby tofsjonas » 06. March 2013 16:48

Hello!

I just made a clean install of 1.8.1 on a linux ubuntu 12.10 machine. When trying to send an e-mail with swiftmailer I get the following error:

preg_match(): Compilation failed: internal error: previously-checked referenced subpattern not found at offset 4246

Googling it I find that it appears to be a problem with pcre. Apparently 8.12 has some issues that are fixed in 8.13 (The current version of pcre is 8.32.). At least that's what I gathered, I could be wrong.

I have NO idea how I would upgrade pcre to 8.32 in xampp. Does anyone know how?

Thanks,

Jonas :)
tofsjonas
 
Posts: 2
Joined: 06. March 2013 16:36
XAMPP Version: 5.6.3
Operating System: Linux Ubuntu 12.10

Re: problem with swiftmailer/pcre in 1.8.1 in ubuntu 12.10 :

Postby Nobbie » 07. March 2013 12:28

tofsjonas wrote:I have NO idea how I would upgrade pcre to 8.32 in xampp. Does anyone know how?


You can't. That is a known disadvantage of using Xampp, as you cannot upgrade any portion on yourself. For the ease of use and installation, the Xampp binaries libraries are always kind of "outdated". For an upgrade you have to wait for a new Xampp release.

In your case, i would not use Xampp, but install Apache/Mysql/Php etc. directly from Ubuntu. You may also install the Server Version of Ubuntu (instead of Desktop Version), as it comes with a pre-installed Server Environment.
Nobbie
 
Posts: 6499
Joined: 09. March 2008 13:04

Re: problem with swiftmailer/pcre in 1.8.1 in ubuntu 12.10 :

Postby tofsjonas » 08. March 2013 14:16

ok, thanks :)
tofsjonas
 
Posts: 2
Joined: 06. March 2013 16:36
XAMPP Version: 5.6.3
Operating System: Linux Ubuntu 12.10


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests