Error 403 Access Forbidden

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error 403 Access Forbidden

Postby clintonshane84 » 17. December 2012 13:40

Hi to all the Apache Friends. I am having a problem with cgi-bin settings. I am running OpenSUSE 12.2 and am using XAMPP 1.8.0. I want to change the cgi-bin Directory settings in the httpd.conf folder but the moment I do that and restart the apache server, I get the error 403 access forbiden message where it was not giving this message until I made a change to the cgi-bin settings section. Here is what I changed:

<IfModule cgid_module>
# ScriptSock: On threaded servers, designate the path to the UNIX
# socket used to communicate with the CGI daemon of mod_cgid.
#Scriptsock logs/cgisock

# "/opt/lampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
<Directory "/opt/lampp/cgi-bin">
AllowOverride None
Options ExecCGI
Order allow,deny
Allow from all

Which was:

<Directory "/opt/lampp/cgi-bin">
AllowOverride None
Require all denied

I have uninstalled and reinstalled fresh the XAMPP installation and tried changing this setting, and over and over this problem reoccurs. What is the problem and what am I doing wrong?

Please find the link to my httpd.conf file:

Please can anyone shed some light on this matter for me.

Kind regards,

Clinton Wright
Posts: 1
Joined: 17. December 2012 13:28
Operating System: OpenSUSE 12.2

Re: Error 403 Access Forbidden

Postby Altrea » 17. December 2012 16:59

Hi clintonshane84,

clintonshane84 wrote:Order allow,deny
Allow from all

old Syntax.

Try instead this new syntax:
Code: Select all
Require all granted

best wishes,
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
AF Moderator
Posts: 9355
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 11 guests