XAMPP and myphpadmin

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP and myphpadmin

Postby siawacsh » 23. October 2012 00:22


Here is my basic info.

I am using Ubuntu 10.10

Broswer is firefox 16.0.1

XAMPP 1.8.1

I installed XAMPP a few days ago seemingly trouble free. I could open and work with files. The troulbes started when I tried to connect to MySql using myphpadmin.

The initial symptom was

(./config.inc.php) is not readable.

Below were the file permissions
for ./config.inc.php

-rw-----w- 1 664 daemon 1459 2012-10-20 23:27 config.inc.php

Any attempt at setting permissions with chmod were ineffective.

I then installed myphpadmin according to this link


This brought up the MySql login but it would not let me in.

According to XAMPP readme I tried lampp for password and nobody for username without success.

My next step was to remove myphpadmin >> then removed XAMPP and reinstalled. I used to following command to remove XAMPP

#rm -rf /opt/lampp

Having reinstalled without any errors XAMPP fails to connect to localhost/index.php

Can anyone help?

Many thanks in advance
Posts: 1
Joined: 22. October 2012 20:31
Operating System: Ubuntu 10.10

Re: XAMPP and myphpadmin

Postby JonB » 31. October 2012 18:33

You likely have a file ownership problem.

generally all the files under /opt/lampp should belong to nobody:group

Good Luck

User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests