MySQL stopped working

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySQL stopped working

Postby bogods » 11. August 2012 21:16

Hi,

I have been running XAMPP 1.8.0 on Puppy Linux Slacko 5.3.3 for sometime without a problem. One day I log on and it says the following error message:
Code: Select all
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!


I have tried everything I could think of, wiping and starting again, even with a fresh download. Tried downgrading to previous versions and suffered the same problem. Also tried a variety of permissions changes as stated in a few posts on this forum to no avail.

What could be causing this error?

Thanks in advance, your help is really appreciated!

Luke :)
bogods
 
Posts: 4
Joined: 11. August 2012 21:09
XAMPP Version: 5.6.3
Operating System: Puppy Linux Slacko 5.3.3

Re: MySQL stopped working

Postby Kristian Marcroft » 12. August 2012 00:29

Hi Luke,

please have a look at the following directory:
# /opt/lammp/var/mysql

In this diretory you will find a *.err file.
Could you please paste the last 10 - 15 lines here?

Thanks
Kristian
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: MySQL stopped working

Postby bogods » 12. August 2012 00:35

Hi Kristian,

Thanks for your response, here's the output:

Code: Select all
120811 20:58:38 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/puppypc23238.pid ended
120811 21:11:51 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
120811 21:11:51 [Note] Plugin 'FEDERATED' is disabled.
120811 21:11:51 InnoDB: The InnoDB memory heap is disabled
120811 21:11:51 InnoDB: Mutexes and rw_locks use InnoDB's own implementation
120811 21:11:51 InnoDB: Compressed tables use zlib 1.2.3
120811 21:11:52 InnoDB: Initializing buffer pool, size = 16.0M
120811 21:11:52 InnoDB: Completed initialization of buffer pool
InnoDB: Error: auto-extending data file /opt/lampp/var/mysql/ibdata1 is of a different size
InnoDB: 0 pages (rounded down to MB) than specified in the .cnf file:
InnoDB: initial 640 pages, max 0 (relevant if non-zero) pages!
120811 21:11:52 InnoDB: Could not open or create data files.
120811 21:11:52 InnoDB: If you tried to add new data files, and it failed here,
120811 21:11:52 InnoDB: you should now edit innodb_data_file_path in my.cnf back
120811 21:11:52 InnoDB: to what it was, and remove the new ibdata files InnoDB created
120811 21:11:52 InnoDB: in this failed attempt. InnoDB only wrote those files full of
120811 21:11:52 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
120811 21:11:52 InnoDB: remove old data files which contain your precious data!
120811 21:11:52 [ERROR] Plugin 'InnoDB' init function returned error.
120811 21:11:52 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
120811 21:11:52 [ERROR] Unknown/unsupported storage engine: InnoDB
120811 21:11:52 [ERROR] Aborting

120811 21:11:52 [Note] /opt/lampp/sbin/mysqld: Shutdown complete

120811 21:11:52 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/puppypc23238.pid ended


Thoughts?

Thanks, and once again I really appreciate your help,

Luke :)
bogods
 
Posts: 4
Joined: 11. August 2012 21:09
XAMPP Version: 5.6.3
Operating System: Puppy Linux Slacko 5.3.3

Re: MySQL stopped working

Postby Kristian Marcroft » 12. August 2012 11:30

Hey Luke,

Please send me the output of:

# ls -la /opt/lampp/var/mysql

It looks as though you have wrong permissions set.

Regards,
Kristian
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: MySQL stopped working

Postby bogods » 12. August 2012 15:02

Hi Kristian,

Thanks for getting back to me, here's the output:

Code: Select all
total 56
drwxrwxr-x 7 nobody root    4096 2012-08-12 14:47 .
drwxr-xr-x 6 root   root    4096 2012-08-06 10:36 ..
drwx------ 2 nobody root    4096 2007-03-24 02:54 cdcol
-rw-rw---- 1 nobody nobody     0 2012-08-05 22:31 ibdata1
drwx------ 2 nobody root    4096 2011-01-10 21:49 mysql
-rw-r--r-- 1 nobody root       5 2011-01-10 21:49 mysql_upgrade_info
drwx------ 2 nobody root    4096 2011-01-10 21:49 performance_schema
drwx------ 2 nobody root    4096 2011-05-17 21:15 phpmyadmin
-rw-rw---- 1 nobody root   22364 2012-08-12 14:47 puppypc23238.err
drwx------ 2 nobody root    4096 2010-05-04 18:29 test


Just to note that puppy runs by default as root, so root is essentially my user.

Thanks so much for your help,

Luke :)
bogods
 
Posts: 4
Joined: 11. August 2012 21:09
XAMPP Version: 5.6.3
Operating System: Puppy Linux Slacko 5.3.3

Re: MySQL stopped working

Postby JonB » 13. August 2012 15:22

Code: Select all
120811 21:11:52 [ERROR] Plugin 'InnoDB' init function returned error.
120811 21:11:52 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
120811 21:11:52 [ERROR] Unknown/unsupported storage engine: InnoDB
120811 21:11:52 [ERROR] Aborting


:shock:

Take a look at his -

http://forum.mamp.info/viewtopic.php?f=2&t=16171

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: MySQL stopped working

Postby bogods » 15. August 2012 22:22

Thanks :)
bogods
 
Posts: 4
Joined: 11. August 2012 21:09
XAMPP Version: 5.6.3
Operating System: Puppy Linux Slacko 5.3.3

Re: MySQL stopped working

Postby JonB » 15. August 2012 22:38

Did that fix work???

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests