Appache 2.2.21 installation issue

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Appache 2.2.21 installation issue

Postby huda » 27. July 2012 11:44

Hi team,

i am struggling to installing apache httpd 2.2.22 on AIX 6.1 TL6. I ran ./configure --prefix=/opt/appache

however when I run make according to the install guide from appache, it throws the following error.


Making all in support
/opt/httpd-2.2.21/srclib/apr/libtool --silent --mode=link gcc -pthread -O2 -Wl,-brtl -o htpasswd htpasswd.lo -Wl,-uXML_Parse -lm /opt/httpd-2.2.21/srclib/pcre/libpcre.la /opt/httpd-2.2.21/srclib/apr-util/libaprutil-1.la /opt/httpd-2.2.21/srclib/apr-util/xml/expat/libexpat.la -liconv /opt/httpd-2.2.21/srclib/apr/libapr-1.la -lpthread
ld: 0711-596 SEVERE ERROR: Object .libs/htpasswd.o
An RLD for section 2 (.data) refers to symbol 1112,
but the storage class of the symbol is not C_EXT or C_HIDEXT.
collect2: ld returned 12 exit status
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
====

A quick response is much appreciated.
Regards,
shaikh Huda
huda
 
Posts: 2
Joined: 27. July 2012 11:29
XAMPP Version: 5.6.3
Operating System: AIX

Re: Appache 2.2.21 installation issue

Postby JonB » 27. July 2012 16:55

I'm now quite unsure at all what you want to do

A:
i am struggling to installing apache httpd 2.2.22 on AIX 6.1 TL6. I ran ./configure --prefix=/opt/appache


what does that have to do with XAMPP?

B. AIX is NOT a supported architecture for XAMPP/lampp. As far as I know, its 'wrong processor architecture' issue. Although XAMPP/lampp is a Linux?inix package its compiled only to run on IA64 and x86 processors. (nor is ARM or Itanium supported)

http://en.wikipedia.org/wiki/IBM_AIX

Good Luck
8)


ysfs
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests