MySQL doesn't start

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySQL doesn't start

Postby blablabla » 17. March 2012 02:56

I just installed XAMPP but MySQL doesn't start and I've looked up using Google but their solutions apparently aren't applicable. This is the MySQL error I got:

Code: Select all
120317 04:40:03 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
120317  4:40:03 [Note] Plugin 'FEDERATED' is disabled.
120317  4:40:03 InnoDB: The InnoDB memory heap is disabled
120317  4:40:03 InnoDB: Mutexes and rw_locks use InnoDB's own implementation
120317  4:40:03 InnoDB: Compressed tables use zlib 1.2.3
120317  4:40:03 InnoDB: Initializing buffer pool, size = 16.0M
InnoDB: mmap(17088512 bytes) failed; errno 12
120317  4:40:03 InnoDB: Completed initialization of buffer pool
120317  4:40:03 InnoDB: Fatal error: cannot allocate memory for the buffer pool
120317  4:40:03 [ERROR] Plugin 'InnoDB' init function returned error.
120317  4:40:03 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
120317  4:40:03 [ERROR] Unknown/unsupported storage engine: InnoDB
120317  4:40:03 [ERROR] Aborting

120317  4:40:03 [Note] /opt/lampp/sbin/mysqld: Shutdown complete

120317 04:40:03 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/radiolibre.pid ended
120317 04:40:29 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
120317  4:40:29 [Note] Plugin 'FEDERATED' is disabled.
120317  4:40:29 InnoDB: The InnoDB memory heap is disabled
120317  4:40:29 InnoDB: Mutexes and rw_locks use InnoDB's own implementation
120317  4:40:29 InnoDB: Compressed tables use zlib 1.2.3
120317  4:40:29 InnoDB: Initializing buffer pool, size = 16.0M
InnoDB: mmap(17088512 bytes) failed; errno 12
120317  4:40:29 InnoDB: Completed initialization of buffer pool
120317  4:40:29 InnoDB: Fatal error: cannot allocate memory for the buffer pool
120317  4:40:29 [ERROR] Plugin 'InnoDB' init function returned error.
120317  4:40:29 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
120317  4:40:29 [ERROR] Unknown/unsupported storage engine: InnoDB
120317  4:40:29 [ERROR] Aborting

120317  4:40:29 [Note] /opt/lampp/sbin/mysqld: Shutdown complete

120317 04:40:29 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/radiolibre.pid ended


Too technical text for me. Would you mind telling me what might be the problem? Thank you in advance.
blablabla
 
Posts: 2
Joined: 17. March 2012 02:51
Location: Chile.
XAMPP Version: 5.6.3
Operating System: Linux Debian

Re: MySQL doesn't start

Postby blablabla » 18. March 2012 01:53

Nothing?
blablabla
 
Posts: 2
Joined: 17. March 2012 02:51
Location: Chile.
XAMPP Version: 5.6.3
Operating System: Linux Debian


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests