MySQL Doesn't Start [SOLVED]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySQL Doesn't Start [SOLVED]

Postby DennisDix » 10. March 2012 21:24

I downloaded lampp 1.7.7 and opened the package in /opt/lampp on Ubuntu 8.0.4
I get the error message "Couldn't start MySQL"

I haven't done anything except unzip the package so I don't know why nobody else has this problem.
I have older versions of lampp on the machine also, and to run the new ones I just renamed the older ones lampp->lamppOld, but I don't see why that should be a problem, since lampp is completely self contained within the directory.
I also tried it on Ubuntu 10.10 with the same results.

Any help would be appreciated.

[EDIT by Altrea: moved to the english section of this board]
DennisDix
 
Posts: 2
Joined: 10. March 2012 21:10
XAMPP Version: 5.6.3
Operating System: ubuntu 8.04

SOLVED Re: MySQL Doesn't Start

Postby DennisDix » 11. March 2012 20:41

I actually did more than just unzip the lampp 1.7.7 file. I extracted the file and then copied the contents to /opt/lampp.
This was a mistake since Ubuntu when it copies files it doesn't always do it cleanly. I think sometimes it drops ./ files or changes permissions.

This time I extracted the zip file exactly where I needed it and it worked fine. Next time I'll know better.
DennisDix
 
Posts: 2
Joined: 10. March 2012 21:10
XAMPP Version: 5.6.3
Operating System: ubuntu 8.04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 11 guests