Problems with phpmyadmin after reinstallation [SOLVED]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Problems with phpmyadmin after reinstallation [SOLVED]

Postby mateuszch » 19. February 2012 00:52

Hello everyone,

I've got a problem with phpmyadmin. The thing is, I've installed XAMPP, but due to fact I had phpmyadmin in German language, I've decided to remove it and install it again from a different source. After second installation it turned out, that my phpmyadmin is still in German and what is more, it is not even working, here is what I get in german when I try to open phpmyadmin:

Code: Select all
Fehler
MySQL meldet:

#2002 - Der Server antwortet nicht. (evtl. ist auch der Socket des lokalen MySQL-Servers socket nicht korrekt konfiguriert)

Verbindung für den controluser, wie er in Ihrer Konfiguration angegeben ist, ist fehlgeschlagen.


I find it strange, since when I write in console lampp start what I get is:

Code: Select all
Starting XAMPP for Linux 1.7.7...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.


Apart from installing XAMPP, I didn't configure it and I didn't use it. What might be important is that after removing XAMPP I realized I've forgotten to stop it.

If anyone could tell me how to fix that, I would appreciate it.

Thank you in advance for your help :)

Regards
mateuszch
 
Posts: 3
Joined: 19. February 2012 00:38
XAMPP Version: 5.6.3
Operating System: Arch Linux

Re: Problems with phpmyadmin after reinstallation

Postby JonB » 19. February 2012 17:48

what does this mean?

The thing is, I've installed XAMPP, but due to fact I had phpmyadmin in German language, I've decided to remove it and install it again from a different source. After second installation it turned out, that my phpmyadmin is still in German


Did you reinstall all of XAMPP and then try to install phpyAdmin from another source??? :?:

The solution is dependent on your answer
:wink:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Problems with phpmyadmin after reinstallation

Postby mateuszch » 19. February 2012 21:13

No, I've reinstalled whole XAMPP, not just phpmyadmin.
mateuszch
 
Posts: 3
Joined: 19. February 2012 00:38
XAMPP Version: 5.6.3
Operating System: Arch Linux

Re: Problems with phpmyadmin after reinstallation

Postby JonB » 20. February 2012 15:01

Under the working assumption that you correctly 'removed' lampp before re-installing -

Fixing the 'connect issue' (I don't know if it makes any difference the order you enter parameters in, as I think its used to populate an array, but it couldn't hurt to make it the first parameter after the i++ ; and comments

Code: Select all
$i++;

/* Authentication type and info */
# commented out by lampp security
#$cfg['Servers'][$i]['auth_type'] = 'config';


Read:
http://localhost/phpmyadmin/Documentation.html

$cfg['Servers'][$i]['socket'] string
The path to the socket to use. Leave blank for default.
To determine the correct socket, check your MySQL configuration or, using the mysql command–line client, issue the status command. Among the resulting information displayed will be the socket used.


Code: Select all
$cfg['Servers'][$i]['socket'] = '/opt/lampp/var/mysql/mysql.sock' ;



To change the Language preference in phpMyAdmin
read this:
viewtopic.php?f=16&t=49839&p=192203&hilit=german#p192203

Let's hope this fixes your issues. If it doesn't, I suspect a bad install/corrupt DL perhaps.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Problems with phpmyadmin after reinstallation

Postby mateuszch » 15. March 2012 23:43

Hello!

I've done what you adviced me and it worked. Thank you very much! :)
mateuszch
 
Posts: 3
Joined: 19. February 2012 00:38
XAMPP Version: 5.6.3
Operating System: Arch Linux


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests