phpmyadmin login error?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

phpmyadmin login error?

Postby Web_Related » 22. March 2004 15:09

Everything was working correctly...until I set the passwords for pma and root in MySQL. Now I get the following error when logging into phpmyadmin:

#1045 - Access denied for user: 'pma@localhost' (Using password: NO)


Help!?! I will continue researching this and report back if I get an answer before someone responds.

Thanks in adance.

Mitch.
Web_Related
 
Posts: 6
Joined: 19. March 2004 16:44

Postby Wiedmann » 22. March 2004 15:31

Have you changed this setting in "config.inc.php" too?:
$cfg['Servers'][$i]['controlluser'] = 'pma';
$cfg['Servers'][$i]['controllpass'] = 'secret';
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

phpmyadmin login error?

Postby Web_Related » 22. March 2004 17:29

I had tried that (I think) and still was getting the error. I tried a lot of stuff.

I did just get it working...

What ended up working for me was the following:
--------------------------------------------------------
log into mysql as root:
./mysql -uroot -p
after entering the password preform the following
mysql> use mysql
mysql> UPDATE mysql.user SET Host='%' WHERE User='pma';
mysql> FLUSH PRIVILEGES;
mysql> quit

Now stop and restart mysql.
-------------------------------------------------------

After that it let me log in as root.
If I log in as pma it says: "Cannot login to MySQL server"

Prior to running the above mysql commands the mysql.user table had a Host value of 'localhost'. After the value was changed to % which is a wildcard meaning 'from anywhere'.

I did not change root's Host values.

This seems to be correct behavior, let me know if it is not.

Thanks again for the information and help.
Web_Related
 
Posts: 6
Joined: 19. March 2004 16:44

phpmyadmin login error?

Postby Web_Related » 22. March 2004 17:48

Hmmm....

I do need the change in config.inc.php

Without it I can log in but can not create tables, or perform most admin functions.

BUT...now that I added the entry, I'm getting the error:

MySQL said:

#1045 - Access denied for user: 'pma@localhost' (Using password: YES)


Notice the only change in the error is the YES (use to be NO).

Back to the drawing board. I am going to regroup review what I have done and see what I can figure out.
Web_Related
 
Posts: 6
Joined: 19. March 2004 16:44

closer to an answer

Postby Web_Related » 22. March 2004 19:29

O.K. I now have phpmyadmin working with all functions...

This is what I did:

/opt/lampp/lampp stopmysql
/opt/lampp/bin/mysqld_safe --skip-grant-tables &

Now I log in and I can do whatever I want!

So is there a simple way to do this using the lampp config files or by modifying the lampp script?

I'll use it this way for now until someone tells me the right way to do it.
Web_Related
 
Posts: 6
Joined: 19. March 2004 16:44


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests