Strange problem after Xampp version upgrading

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Strange problem after Xampp version upgrading

Postby smashpunk » 24. December 2011 09:14

Dears,I've upgraded my Xampp from version 1.6.8a to 1.7.7 successfully,one upgrading by another. :)
But,when I'm checking Apache's version,I find a strange situation here,and it confused me so much:
Apache's version is much low than which combined in Xampp 1.7.7!
According to the RELEASENOTES of Xampp 1.7.7,Apache's version should be Apache 2.2.21,but my Apache's version is 2.2.6.
What's wrong? :?:
BTW,I make another machine to confirm this issue--I installed Xampp 1.7.7 on another Fedora,and got the same issue. :cry:

-bash-3.2# /opt/lampp/lampp stop
Stopping XAMPP for Linux 1.7.7...
XAMPP: Stopping Apache with SSL...
XAMPP: Stopping MySQL...
XAMPP: Stopping ProFTPD...
XAMPP stopped.
-bash-3.2# /opt/lampp/lampp start
Starting XAMPP for Linux 1.7.7...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.
-bash-3.2# httpd -v
Server version: Apache/2.2.6 (Unix)
Server built: Sep 18 2007 09:40:44


Happy New Year! (if you are still fighting on the support line 8) )
Xampp Version:1.7.7
Operation System:Fedora7
smashpunk
 
Posts: 5
Joined: 24. December 2011 08:47
XAMPP Version: 5.6.3
Operating System: Fedora

Re: Strange problem after Xampp version upgrading

Postby JonB » 27. December 2011 17:48

OK -

Here is output from term on my Fedora 15 Linux box that is running XAMPP/LAMPP -

Code: Select all
[jonb@localhost ~]$ su
Password:
[root@localhost jonb]# httpd -v
bash: httpd: command not found...
Install package 'httpd' to provide command 'httpd'? [N/y]
[root@localhost jonb]#


What is happening there?
BECAUSE XAMPP/LAMPP is NOT a standard LAMP stack - Linux does not 'think' httpd is installed (so Fedora wants to install the available 'httpd' package from the repo libraries I have installed. SO I wisely keyed 'n'...

IN your case - httpd HAS been installed in the past (it was likely part of the 'flavor' you chose -even if not active), and it (Fedora) is properly reporting the 'old' installed version number from the Linux distribution package... You don't mention 'which' Fedora we are talking about, so its impossible to say much more. OTAY???

Note: - If you want to know what LAMPP really does - open the /opt/lampp/lampp file (its an executable bash script)

So WHAT is the correct syntax for "Find Apache version for LAMPP??? "
~tada~

Code: Select all
[jonb@localhost ~]$ su
Password:
[root@localhost jonb]# /opt/lampp/bin/apachectl -v
Server version: Apache/2.2.17 (Unix)
Server built:   Oct 21 2010 10:24:42
[root@localhost jonb]#

(Note, I am running XAMPP for Linux 1.7.4 not 1.7.7)

Tonight I will do a look-see and tell you what my 'other' Fedora 15 box with a pure LAMP stack reports...
http://docs.fedoraproject.org/en-US/Fed ... Admin.html
and here is the output from My Fedora 15 LAMP stack:

Code: Select all
[jonb@localhost ~]$ su
Password:
[root@localhost jonb]# httpd -v
Server version: Apache/2.2.21 (Unix)
Server built:   Sep 13 2011 13:46:23
[root@localhost jonb]# uname -arv
Linux localhost.localdomain 2.6.41.4-1.fc15.i686.PAE #1 SMP Tue Nov 29 11:47:02 UTC 2011 i686 i686 i386 GNU/Linux
[root@localhost jonb]#


Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Strange problem after Xampp version upgrading

Postby smashpunk » 29. December 2011 09:47

I've checked my Fedora,and you are right.There is an old package httpd-2.2.6-a.fc7 installaed in 2007~~~
-bash-3.2# rpm -qa|grep httpd
httpd-2.2.6-1.fc7
I believe if I remove this package(httpd-2.2.6-1.fc7),Xampp won't been influenced,right?
Have a nice day,JonB :)
Xampp Version:1.7.7
Operation System:Fedora7
smashpunk
 
Posts: 5
Joined: 24. December 2011 08:47
XAMPP Version: 5.6.3
Operating System: Fedora

Re: Strange problem after Xampp version upgrading

Postby JonB » 29. December 2011 14:03

Hi smashpunk

You are basically correct, the installed package could be removed, and that action should not affect XAMPP's functionality. XAMPP is 'OS neutral' (self contained).

However, I don't recommend you do that. (note that is a "i" there, LOL) Here is why:

When that package was installed, it is likely many other things were done to resolve dependencies. Why chance breaking your box? As long as Fedora is not firing up the 'old Apache', let sleeping dogs lie. The /opt/lampp/bin/apachectl file provides all the command functions for httpd. (its actually the preferred method) http://httpd.apache.org/docs/current/invoking.html

I see you know some '*nix-speak', so a look into /etc/inittab or /etc/rc.d/rc.local (I don't know FC7 so it could be either, inittab is deprecated) would be a way to see what's happening.

BTW - If you would like to auto-launch LAMPP, here is a link on how to do that:
viewtopic.php?f=17&t=48730

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Strange problem after Xampp version upgrading

Postby smashpunk » 30. December 2011 13:16

Dear JonB
Thanks for your quick feedback.I also choose your way:let sleeping dogs lie, :D
Do the least action on system, and keep most things as they were,my working habit :D

BTW,you know I upgraded Xampp from 1.6.8a to 1.7.7.But,after upgrading I got an error like "cannot restore segment prot after reloc: Permission denied".
And I got a solution from Linux FQA---"setenforce 0" to temporarily set SElinux to permissive mode.
I'm not experienced on SElinux,but according to my intuition,disable SElinux of Fedora is not a good idea.
In this situation,if I want to run Xampp automatically,I may need to write a short script to disable SElinux before starting Xampp,then enable SElinux after Xampp starting.
This is my draft idea,but it looks strange anyway :shock:
Xampp Version:1.7.7
Operation System:Fedora7
smashpunk
 
Posts: 5
Joined: 24. December 2011 08:47
XAMPP Version: 5.6.3
Operating System: Fedora

Re: Strange problem after Xampp version upgrading

Postby JonB » 30. December 2011 15:41

If you look in the /opt/lampp/lampp bash script, you will see there is a hack for SE Linux. I have not yet taken the time to analyze exactly what it does. (but I am sure I will be doing that) I also need see how a Linux shutdown works with the lampp script and the running processes. (A geek never runs out of things to figure out) :lol:

I think the only time you should run into a problem is if you have 'working data folders' under htdocs (that is only my experience). I have this issue from running various frameworks, some of which need to have working folders, session variables or temp folders under the DocumentRoot to function correctly. So I permanently run my LAMPP box in permissive mode, and auto-start it (LAMPP) with that modification to /etc/rc.d/rc.local. It works very nicely for me. SE Linux is mostly aimed at preventing actions that would diminish security at a workstation and network level. If you understand Apache web server configuration and good security procedures, SE Linux will have little or no effect on what you are doing.

This is good article about SE Linux - (and shows the hack you would need to add to do what you were thinking)
http://www.crypt.gen.nz/selinux/disable_selinux.html

Anyway - Good Luck with your projects and have a Happy and Prosperous New Year.

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Strange problem after Xampp version upgrading

Postby smashpunk » 31. December 2011 03:29

I use ln command to add /opt/lampp/lampp to rc5.d,it works.
And I choose to configure /etc/selinux/configure to switch SElinux into permissive mode.
Meanwhile I will trying to find another way to run Xampp on enabled SElinux, hope I can get some finding.

Happy New Year!~~
Xampp Version:1.7.7
Operation System:Fedora7
smashpunk
 
Posts: 5
Joined: 24. December 2011 08:47
XAMPP Version: 5.6.3
Operating System: Fedora


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests