Proftpd user nobody has no permissions [Solved]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Proftpd user nobody has no permissions [Solved]

Postby Ufonautas » 26. November 2011 19:40

Hey,

I have one little problem, when i connect to ftp ( localhost:21 nobody:lampp ) i can see all folders in httdocs, but i cant create any new folders.
I think user nobody has no permissions to do that.

Screenshot: http://i40.tinypic.com/m9pusz.png
Ufonautas
 
Posts: 3
Joined: 26. November 2011 19:28
Operating System: Ubuntu Linux

Re: Proftpd user nobody has no permissions

Postby JonB » 26. November 2011 20:03

Try doing it from another machine. :shock:

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Proftpd user nobody has no permissions

Postby Ufonautas » 27. November 2011 09:49

Thanks for reply!

But i'm trying to connect to ftp via php. And the only thing that php can do is list files in ftp, it gives me error while i try to create or delete folder.
Ufonautas
 
Posts: 3
Joined: 26. November 2011 19:28
Operating System: Ubuntu Linux

Re: Proftpd user nobody has no permissions

Postby JonB » 27. November 2011 10:07

OK -

Should I take it that you have given 'nobody' full rights and ownership to the FTP folder at the filesystem level???

From personal experience, I'm pretty confident that its a permissions issue (as you say), although I haven't figured out the dynamics of it. For instance, you have the same problem if you try to update Wordpress on localhost (using 'via FTP' option) - you just can't do it, even if you have the right credentials. Its not just on Linux, I have that issue on Windows/Apache as well (which kind of sets aside the Linux filesystem permissions issue). I think the problem is that 'you' (the process) are already 'someone' else on the system, and that someone does not have the right to grant (or maybe I should say 'can't' grant) privileges to another user to use another protocol. I'm thinking of execution privileges, like within Apache. In fact, now that I have typed that - I think that's it its a protocol issue, maybe inside Apache.

A few suggestions -

You also might want to look at the code Wordpress uses for that function, and maybe test it (a quick WP install) and see if it has the same issue (update via FTP on localhost)

Try creating a file - see what happens -

I suggest you try the same code with a second machine set up to be the target. OR try the script as CGI. If either works, it bears out my scenario.

Good Luck.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Proftpd user nobody has no permissions

Postby Ufonautas » 27. November 2011 11:59

Thanks for reply again, now i figured out how to let ftp user "nobody" do anything on httdocs folder.

Now, if anyone will every have the same problem:

Easy way is to: Right click, properties, permissions and let "Others" to create and delete files ( http://i42.tinypic.com/300qjp3.png ).

The better way is to use chown command via terminal.

I'm using easy way, becouse i have only local ip, so noone can connect to my computer. If you have external ip doing it "easy" way is dangerous.

Thanks, JonB for help!
Now you can mark this tread as Solved :)
Ufonautas
 
Posts: 3
Joined: 26. November 2011 19:28
Operating System: Ubuntu Linux

Re: Proftpd user nobody has no permissions [Solved]

Postby JonB » 27. November 2011 14:01

Glad you figured it out AND posted the answer -

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests