XAMPP won't Start!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP won't Start!

Postby epsteins » 23. November 2011 01:24

Running Fedora 14.

I follow the instructions listed at
http://www.apachefriends.org/en/xampp-linux.html#372

When I get to Step 3: Start, here's what happens...

[root@epsteins Downloads]# /opt/lampp/lampp start
Starting XAMPP for Linux 1.7.7...
/opt/lampp/bin/php: error while loading shared libraries: libz.so.1: cannot enable executable stack as shared object requires: Permission denied
XAMPP: Starting Apache with SSL ...
/opt/lampp/bin/httpd: error while loading shared libraries: libexpat.so.0: cannot enable executable stack as shared object requires: Permission denied
XAMPP: Error 127! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
/opt/lampp/bin/my_print_defaults: error while loading shared libraries: libz.so.1: cannot enable executable stack as shared object requires: Permission denied
XAMPP: Couldn't start MySQL!
XAMPP: Starting ProFTPD...
XAMPP: /opt/lampp/sbin/proftpd: error while loading shared libraries: libcrypto.so.1.0.0: cannot enable executable stack as shared object requires: Permission denied
XAMPP: Error 127! Couln't start ProFTPD!
XAMPP for Linux started.


What's wrong?
epsteins
 
Posts: 2
Joined: 23. November 2011 01:10
Operating System: Fedora 14

Re: XAMPP won't Start!

Postby JonB » 23. November 2011 01:42

Two questions

what user and group are the owners of /opt/lampp and its subfolders???

did you introduce a php.ini file from another instance?


Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: XAMPP won't Start!

Postby epsteins » 23. November 2011 02:01

Solved!
epsteins
 
Posts: 2
Joined: 23. November 2011 01:10
Operating System: Fedora 14

Re: XAMPP won't Start!

Postby JonB » 23. November 2011 09:59

It would be useful for others to know the 'real problem/solution' for the future...

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 11 guests