Error 139! Couldn't start Apache!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error 139! Couldn't start Apache!

Postby rubendcastro1 » 15. November 2011 03:31


I have problem whit Xampp server over Archlinux whit this message:

/opt/lampp/bin/apachectl: line 78: 3450 Segmentation fault $HTTPD $ARGV
XAMPP: Error 139! Couldn't start Apache!

Help me pleace.

Tks Rubén
Posts: 1
Joined: 15. November 2011 03:25
Operating System: linux

Re: Error 139! Couldn't start Apache!

Postby Sharley » 15. November 2011 03:47

Hello Rubén,

Please add your correct Linux distro to your forum profile:

Thanks. :)
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error 139! Couldn't start Apache!

Postby JonB » 15. November 2011 07:31

LAMPP does not work quite like standard LAMP stacks.

please try starting LAMPP with this command (as root)

/opt/lampp/lampp start

See if LAMPP starts ok, please...

Was LAMPP stopped when you issued that command??? or were you trying to 'start Apache'????

LAMPP is run by a bash script (/opt/lampp/lampp), with a set of delimited options (arguments) that are invoked by that script. What I am saying is you may not be able to use some Apache CLI options.

The arguments are outlined in the LAMPP FAQ's -

(down toward the bottom)

You can also open the bash script (/opt/lampp/lampp) with an editor - look around line 128 for the arguments available (cases)

Good Luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Linux

Who is online

Users browsing this forum: 404usernotfound and 3 guests