Page 1 of 1

XAMPP only shows "It Works!" Page

PostPosted: 06. September 2011 23:08
by websterhamster
Hi,

My apologies if this is a very common problem and I am just too inept to figure it out for myself.

My problem is this: I have a XAMPP installation on Mandriva 2010.2. I have done everything it tells me to do in the installation instructions, and have placed a page in the htdocs folder. (I have used XAMPP successfully on a Windows machine) and all I get is the page saying "It Works!". Well, obviously it doesn't.

I can't figure out how to get my pages to display. It did work once, right after I installed it for the first time. Should I re-download XAMPP and try installing it again?

Thanks for any help!

Re: XAMPP only shows "It Works!" Page

PostPosted: 06. September 2011 23:44
by JonB
OK, let me ask - did you get that in your browser after typing http://localhost :?:
Can you still get the XAMPP Welcome Page - http://localhost/xampp :?:

Did you start XAMPP as root?
su or sudo
/opt/lampp/lampp start
:?:

My recollection is that "It Works" is a page that only gets served when PHP is not working (or the redirector is missing???), although I can't find my notes on that...

Maybe something you did broke XAMPP - any "chown-ing" or "chmod-ing" in htdocs????

It might be quite easy to clean it out and start fresh
BACK ANYTHING UP FIRST!
To remove lampp --
as root:
cd /opt
rm -R -I -v ./lampp
that should do the trick.

http://www.apachefriends.org/en/xampp-linux.html

Good Luck
8)