upgrading FreeType in xampp

Problems with the Linux version of XAMPP, questions, comments, and anything related.

upgrading FreeType in xampp

Postby milsabor2 » 04. September 2011 14:38

You guys are my last chance to solve my problem, because I looked everywhere on the internet and on irc to find a solution, without any results.
I'm trying to install a library with xampp (jpgraph), which requires the freetype library to be 2.2 at least.
When I run a simple php program with xampp, containing only the "phpinfo" function, it occurs that freetype is 2.1.7 with the latest xampp version.

My question is, how to upgrade the freetype library in xampp ?


Posts: 1
Joined: 04. September 2011 14:35

Re: upgrading FreeType in xampp

Postby JonB » 06. September 2011 16:58

Hello Etienne

A. There is no 'simple way' to do this, you would probably need to compile from source as far as I can tell.

B. You really want to read this:

C. You can search for a packaged release that is intended for YOUR Linux/Unix distribution (Fedora, RHEL, Unbuntu, Debian, whatever) i.e. a 'yum', .rpm, .deb etc, designed to support the installer your Linux distro uses - such as yum or apt-get. This is like a precompiled Windows dll/exe, where someone else has worked out all the dependencies, and built a -ready-to-go package.

If you don't understand all/any of this, or are not interested in poking about at this level, this project may be 'a bridge too far' for you at this point. On the other hand, if you want to learn a lot - this could be an interesting adventure. If you are doing anything important with your system, you should learn about backing up before you decide to experiment.

With some luck, maybe someone else will have a better solution...

Good Luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests