Xampp-remote php pages

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Xampp-remote php pages

Postby bradsguaso » 30. August 2011 16:19

I have a Drupal site on Xampp installed (latest version) on Ubuntu Server 8.04. The problem is that when I access the site (some pages) from a client computer(not the server), the browser window opens me to download the page instead of opening it. I think it's because Xampp dont's recognize php pages are indexes, but I am not sure. Could anyone help me?
bradsguaso
 
Posts: 2
Joined: 30. August 2011 15:46

Re: Xampp-remote php pages

Postby JonB » 30. August 2011 17:42

could be...

could also be 'Short Open Tags' issue, although I think the XAMPP/LAMPP defaults to

Well this is interesting - in XAMPP/LAMPP 1.74's default php.ini -- BOTH tag seetings are present:(about line 226-227)
(/opt/lampp/etc/php.ini)

Code: Select all
short_open_tag = Off
; XAMPP for Linux is currently old fashioned
short_open_tag = On


LOL - I'm running LAMPP on this Fedora box right now (easy to check)

Also - easy definitive answer -(try this from the remote machine)

IF you can access http://yourmachinesip/xammp
AND it opens onto the XAMPP Welcome Page or the XAMPP Spalsh - then the problem is most likely NOT that the server is misconfigured.

You may need to fix the 'xammp security concept' for that to work. The PHP settings are also in this file
/opt/lampp/extra/httpd-xampp.conf

Index types are set in the /opt/lampp/etc/httpd.conf

Good Luck
8)

Extra points question - did you set up any vhosts???
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Thanks

Postby bradsguaso » 31. August 2011 22:13

Ok, thank you so much JonB.
bradsguaso
 
Posts: 2
Joined: 30. August 2011 15:46


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests